Skip navigation

Can't edit group access to services

1121 Views 8 Replies Latest reply: Nov 18, 2012 4:47 AM by c2ric RSS
AnalogKid Level 1 Level 1 (10 points)
Currently Being Moderated
Aug 19, 2012 12:43 AM

Within ML, I've created a new group.  When I select "Edit access to services...", the spinner in the bottom right goes forever and never returns.  There is no text next to the spinner.  The services check boxes don't appear.  Both cores on my Mini are at about 80% load, and Activity Monitor reports that that is split between opendirectoryd and servermgrd.  Neither log file shows activity while this is happening. 


The cancel button in the sheet remains active, and closes the sheet.  I can only get out of this by quitting and reopening.  I get a warning that some changes will be unsaved if I quit, but there really isn't much choice.


I can edit services for the Workgroup group, but not for any self created group.

  • Ben Pirozzolo Calculating status...
    Currently Being Moderated
    Aug 23, 2012 6:15 AM (in response to AnalogKid)

    I can only say that i've got the same problem. I unfortunately don't have the luxury of clean installing ML. Just like you, i can edit the default 'Workgroup' group, but the second i try and edit groups created by me, i get the same symptoms as you, the spinner at the bottom right of the server app just carries on spinning while saying nothing, and while the 'Edit Access to Services' box appears, all that is in there is a white square. When that happens, i then can't even edit the 'Workgroup' group, or even touch anything else Open Directory related until i've restarted the machine, as it's clearly stuck doing a task in the background.


    Is there anyway to even debug the server app so i can see what it is doing? As you say, the logs don't seem to be much help.

  • Ben Pirozzolo Level 2 Level 2 (165 points)
    Currently Being Moderated
    Aug 25, 2012 7:52 AM (in response to AnalogKid)

    Just an update in case anyone else in the future has this problem and

    can't work out what the **** to do.

    I managed (after a lot of heartache) to finally stop the service hanging

    by going into the 'Directory Utlity' app, then using the 'Directory

    Editor' to access the /Local/Default node. In there go to the 'Groups'

    section and there is a list of service access records called I deleted all of them, and this fixed the

    hanging. Of course if you had setup any server access settings, you will

    have to do this again. But that's a small price to pay.



  • Ben Pirozzolo Level 2 Level 2 (165 points)
    Currently Being Moderated
    Oct 2, 2012 3:31 PM (in response to AnalogKid)

    Nope, none at all. In fact it was the only thing in Mountain Lion Server that seemed to have a relatively easy fix with no complications.

  • jcorreiad Calculating status...
    Currently Being Moderated
    Oct 6, 2012 8:22 PM (in response to Ben Pirozzolo)

    Followed your advice. It worked. Only thing to add is that i recommend to restart Open Directory or restart the mac if you wish.

  • c2ric Calculating status...
    Currently Being Moderated
    Nov 18, 2012 4:47 AM (in response to AnalogKid)

    Thank's to you

    it's worked!


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.