1 Reply Latest reply: Nov 18, 2012 1:12 PM by laundry bleach
Hostie Level 1 Level 1 (0 points)

I have a new downloaded OS X now my Iphoto version 8.2 needs upgrading I downloaded 9.3 but I cant use it as I need a minimum of 9.1 how do I do this ?


MacBook, OS X Mountain Lion (10.8.2)