Skip navigation

my home sharing is not working

9969 Views 28 Replies Latest reply: Apr 15, 2013 6:39 AM by MoTatt RSS
  • bensrose Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2012 8:13 PM (in response to Trott22)

    Mine is not working either. I have tried restarting, disabling IPv6, rebooting, restarting iTunes and so on. I've checked versions and date time settings. Everything is up to date. The computer and Apple TV are on the same network both behind the same hardware firewall. The software firewall is disabled. I'd be grateful for any suggestions.My box is model MD199C/A - it is black. I'm using an HP Elitebook laptop with Win 7 pro installed. I also restarted the Bonjour service.

  • Rathbone Hall Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 10:56 AM (in response to Trott22)

    Scan the Support Community sites and you will find: Apple TV losing connection is prevalent. The many postings point out the problem occurs with:-

    1 Apple TV1,2and 3;

    2 with different brands of router including Airport Extreme;

    3 with current and past versions of iTunes;

    4 after varying periods of working well.....minutes, hours, days;

    5 losing connection with Home Sharing and losing Airplay;

    6 whether the router and Apple TV are in same room or separated by distance;

    7 after trying innumerable posted 'fixes';

    8 after exchanging for a new Apple TV;

    9 with all the recent operating systems -Mountain Lion, Lion, Snow Leopard, Leopard and Lion.

    10 when it loses wifi, the ATV will work immediately if you plug in the ethernet cable.....Steve Jobs called the ATV a hobby, but Apple products are supposed to be better than this.

    I suspect frustrated  readers just give up trying, rather than find a fix, which is why I invite readers to please don't post a fix until you check it works for at least a week.

  • bensrose Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 11, 2012 11:49 AM (in response to Rathbone Hall)

    Thanks for the response. Oddly, both the TV and iTunes show Apple TV as being connected and the network is showing as properly connected everywhere. The IP address is in the proper range as well. Could it have something to do with having the library on an external hard drive connected to the laptop via a docking station?

  • techstresshead Calculating status...
    Currently Being Moderated
    Sep 8, 2012 1:53 AM (in response to Trott22)

    I can't even find 'home sharing' on itunes!

  • snajnielk Calculating status...
    Currently Being Moderated
    Nov 15, 2012 8:02 AM (in response to Trott22)

    My home sharing started working when I renewed my DHCP lease on my router. Apparently, the router somehow loses the names of the computers after a while, then sharing won't work. Same thing happens with my wifi printer - I have to switch my wifi off/on, then it works. Hope this helps.

  • colinfromdunstable Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2012 12:59 PM (in response to snajnielk)

    I have finally cracked my problem. Homeshare photos on WinXP iTunes 10.7 definitely works with ATV restored using this file: "AppleTV2,1_5.0.2_9B830_Restore.ipsw".

     

    It definitely DOES NOT work with the update which was applied two weeks ago. Sorry I did not take a note of the version number, but if it is dated a week or more ago it is rubbish.

     

    The restore procedure fails on a PC which has other USB devices connected (I didn't try to find which).

     

    You have to hold down the shift key when clicking Restore in order to use the file you downloaded, otherwise you just get the latest version from Apple.

  • ambscotty Calculating status...
    Currently Being Moderated
    Nov 26, 2012 5:29 AM (in response to Trott22)

    my home sharing will not work. it keeps saying cannot connect to i tunes store, check internet connection. i have checked all my connections restarted my computer and same thing happens.

  • colinfromdunstable Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 6:58 AM (in response to ambscotty)

    Have you reverted to "AppleTV2,1_5.0.2_9B830_Restore.ipsw" ?

  • ambscotty Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 2:48 AM (in response to colinfromdunstable)

    No, i haven't reverted to that, because I don't know what that means.  Lol.
    Please help!

  • colinfromdunstable Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 4:10 AM (in response to ambscotty)

    Download AppleTV2,1_5.0.2_9B830_Restore.ipsw from http://iosindex.com/ios/apple-tv/2g/5.0.2-9b830 and remember where you saved it.

     

    Connect ATV2 to PC USB (no power required, but you may need to buy a USB lead)

    Run iTunes any version

    Click on ATV and holding down the shift key, click Restore (or something like it)

    Find your downloaded file and choose it.

     

    This will rid you of the rogue ATV s/w, although it is not quick.

     

    If you get a failure, no problem, just remove all other USB devices (or find a PC which is not using any) and repeat.

     

    Good luck.

  • AReyX Calculating status...
    Currently Being Moderated
    Nov 27, 2012 8:49 PM (in response to Trott22)

    Well, the **** thing certainly holds papers down well in windy situations. Here's a bit of sadness, I work in the IT field, and I've been endorsing this **** thing to my gf who received it as a gift from her co-workers. I'm talking up all of the cool features it has, synced it with iMedia, dropped some cash at the iTunes store, etc... She kep saying that the **** smart TV does the same things... Lol, the TV certainly allows you to watch movies, rather than complain in an Apple forum. Anyway, now she's sleeping on the couch while I try to get this POS to sync with my PC and all I can think about is selling off my iCrap and buyng up Microsuck. Can I get another option please!... oooh. The iTV Apple TV Black Box Dumb Terminal is rebooting... Someone at Apple must be reading my post, and they quickly logged in to help... Bear with me, I'll let all of you know how it works... Step 2 of 2 20 minutes later... Go Grey Bar Go!!! I'm contemplating "unplugging my Apple TV while it updates" 30 minutes passed, girlfriend is snoring, how cute... BLackness! It's dead, hooray!... Wait, the little white light is winking at me... ****, the fn bar is back again, wait now it's just an Apple logo! I have visions of cool soccer Moms driving mini vans... I hope the gf doesn't read this. And we're back up and running. Lets see if I get to watch a movie (by myself now) on the TV after two hours of screwing around with this. Turn iTunage on, check... PC home Sharing on, then off, then on again, check... Clicked computers on the TV, check.... Spinning disc of sadness while "Loading "Home's Library"... Check, and... someone give me a gun and a bullet.

  • cwkent2012 Calculating status...
    Currently Being Moderated
    Jan 4, 2013 8:12 PM (in response to Trott22)

    This may seem simple but I have been working on the same problem.

    I have

    Macbook pro 13 inch mid 2011

    ipad 2

    iphone 4

    iphone 3gs

    itv

     

    Nothing was working after my wife and I switched macbooks. I had all my ID's synced properly and everything was turned on correctly. I kept getting "Cannot Access" error message trying to watch a movie on iPad 2.

     

    Finally I went into my account in itunes and DEAUTHORIZED ALL COMPUTERS. Then REAUTHORIZE the computer you are trying to use the Home Sharing with and everything started working properly.

     

    I did not have to restart router.

     

    Hope this helps

  • OldManWinter Calculating status...
    Currently Being Moderated
    Mar 30, 2013 9:54 AM (in response to Trott22)

    Just got off the phone with support and this fixed my problem...I also had to do a restart of my PC (not in the instructions below). I guess Microsoft added a new protocol or something which caused it to stop working recently (month or two).

     

    First, make sure that the Bonjour service is running on your computer. You can check this by going to Edit > Preferences within iTunes and selecting the Sharing tab. This tab should display sharing options if the Bonjour service is running. Otherwise it will tell you that the Bonjour service is not running. To enable the Bonjour service in Windows 7, follow these steps. 1. Right-click Computer and select Manage. 2. Select Services and Applications > Services. 3. Double-click the Bonjour service, set the Startup type to Automatic. 4. Click Apply. 5. Click the Start button. 6. Close iTunes if it is open, then restart it. If the Bonjour service isn’t your problem, you may have a problem with iTunes trying to route sharing traffic using IP6 instead of IP4. Try these steps in Windows. 1. Open Control Panel. 2. Choose Network and Internet. 3. Select the View network status and tasks under the Network and Sharing Center section. 4. Choose your active network connection. It’s usually named “Wireless Network Connection 1 or something similar. 5. Click the Properties button. 6. If Internet Protocol Version 6 (TCP/IPv6) is checked, uncheck it, then click OK. 7. Click Close. 8. Restart iTunes and try to use the Home Sharing feature again.

  • MoTatt Calculating status...
    Currently Being Moderated
    Apr 15, 2013 6:39 AM (in response to Trott22)

    Just bought new mac lap top trying to share/transfer music from original Imac. Both running 10.8.3. Worked first time then crashed.

    Each machine still shows up in other home sharing box and when clicked starts loading from Imac but times out out???

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.