Skip navigation

Mac Mini 2012 video blinking out

154095 Views 1,193 Replies Latest reply: Mar 29, 2014 2:11 AM by knightshade91 RSS Branched to a new discussion.
  • bradpaulp Calculating status...
    Currently Being Moderated
    Nov 18, 2012 5:34 AM (in response to calvol)

    Sorry calvol its the 6630M card. hopefully you get better results !

     

    (Maybe apple could just trade my samsung monitor for a 27" thunderbolt display, id call it even :/ )

  • LBJ_UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2012 5:55 AM (in response to bradpaulp)

    I was about to buy a Mac Mini 2012 with the 2.6GHz upgrade and 1TB Fusion drive. Fortunately all these forum postings have made me hold off! I was planning on using both the T-Bolt and HMDI display out ports for two identical monitors. However it seems we have two issues, this blinking black/snow on the HDMI out and poor video quality on the HDMI out anyway (see other fora). It's a nightmare, but very little is mentioned in the tech press, bar the ARS Technica review (which couldn't replicate the issue) and Lockergnome.

     

    Is there ANYONE out there with a 2012 Mac Mini that works perfectly on the HDMI out?

     

    Is there ANYONE out there running two identical monitors on HDMI and T-Bolt without any comparative display differences?

  • GetafeMagic Calculating status...
    Currently Being Moderated
    Nov 18, 2012 7:35 AM (in response to KevCheng)

    Hmmmmm

     

    I was about to say i have had no problems since that one blackout yesterday, but I literally just had one about 2 minutes ago, went black for about 2/3 seconds then got a snowy picture for half a second, maybe less. I think I shall be calling Apple first thing tomorrow to let them know my machine is playing up, not as much as some of y'all, but I shouldn't be getting any problems with a machine this price!

     

    I have been looking forward to finally a fast computer for ages, and now I have one, it has a stupid problem. I guess I might have to go back to my old Mac Mini (Early 2009) until this mess is fixed. At the moment I am not sure what I want to do.

  • zymurgyboy Calculating status...
    Currently Being Moderated
    Nov 18, 2012 7:55 AM (in response to KevCheng)

    Since pulling one stick of RAM, I'm now at one week and counting with no issues (it was an hourly event prior to that). I'm going try putting that other stick back to see if I can reproduce the original behavior this afternoon.

     

    My late-2012 Mini has been running as a Plex server and client almost continually in that span of time, playing back all manner of 720p and 1080p videos.

  • SoloCrowd Calculating status...
    Currently Being Moderated
    Nov 18, 2012 7:56 AM (in response to KevCheng)

    It looks like this is an issue that is caused by the Intel HD 4000 and it will need to be fixed with a bios update from the motherboard manufacturer (Apple).

     

    Apparently there is  a work around as noted in the post I link to, which says you can remove one of your sticks or RAM, but I for one will live with the occasional black screen and keep both sticks of RAM in.  Hopefully Apple addresses this issue soon.

     

    http://communities.intel.com/thread/30096?start=0&tstart=0

  • LBJ_UK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2012 11:24 AM (in response to zymurgyboy)

    I'm not sure I'd want to drop to a single channel memory solution whilst utilising integrated graphics. That is pretty shoddy and a rather poor experience for an Apple device. I think I will continue to hold until a resolution is in place.

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 18, 2012 11:34 AM (in response to LBJ_UK)

    I'm aware of 2 Minis that do not have the problem.

  • --A--C-- Level 2 Level 2 (290 points)
    Currently Being Moderated
    Nov 18, 2012 12:31 PM (in response to BDAqua)

    It might seem offtopic, but maybe it's not.

    I've just read this interesting article about HDMI cable quality, from a seemingly very knowledgable person:

    http://news.cnet.com/8301-17938_105-20056502-1/why-all-hdmi-cables-are-the-same/

    particularly this part about cable failure symptoms is interesting:

    "(…) Another potential "fail" is a failure of the HDCP copy protection, which shows up as a total snowy image, a blinking image, or something else hard to miss."

    This is mentioned in the last paragraph of the "video" section, right above the "audio" section.

     

    I'm inclined to think this could be a HDMI "handshake" problem. Since the same symptoms we are seeing can occur with a faulty HDMI cable that has TMDS failures in its HDCP channel, I guess this could very well be hardware related, thus not fixable with a firmware update. Maybe a manufacturing defect/imperfection somewhere in the internal wiring of a batch of Intel HD4000 GPU's?

    Apparently there are people with new mac mini's that don't have issues. Also, people without issues are not very likely to respond to this thread. Also the fact that Apple is collecting faulty minimacs to investigate the problem indicates they can't replicate it with some macmini's that roll out the factory. Some people have it very more frequent and/or longer lasting then others. That could indicate varying degrees of manufacturing defects. If it were a firmware issue, wouldn't we all have the same results?

    I myself only have the blinking a few times a day, sometimes blackouts, sometimes blue screens, but without the snow many of you report. The blue screens I see, are by the way similar to what you see the moment you connect/disconnect a second monitor. As if the mac mini is fooled in thinking a screen was disconnected and then connected again immediately.

     

    Don't know, I'm not an expert, just thinking out loud; but since these HD4000 issues are reported on Intel forums since June, and still not solved by updated BIOS version 1.6

    http://communities.intel.com/message/171244

    I wouldn't assume that it is most probably a firmware issue that can be fixed in the near future.

    I wish I were wrong, but at the moment my hopes for a magical apple update fix, is not very high.

     

    Tuesday I'll have my machine 14days, so I need to decide now if I'm going for a refund.

    I absolutely want to like my new machine, but right now I think it's more wise to send it back.

     

    Any experts on HDMI handshake that could chime in?

  • calvol Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2012 12:47 PM (in response to bradpaulp)

    Bradpaul,   Indeed, the 2011 Mini's also have the same problem, even with the Radeon GPU. So it must be an issue with the HDMI implementation.   I found this informative thread about it, and appears at the very end, one user found that doing a dual SMC/PRAM reset with the monitor DISCONNECTED fixed the issue.  May be worth a try.

     

    https://discussions.apple.com/thread/3229009?start=30&tstart=0

     

    <quote>

     

     

    I have experienced the dreaded sreen flicker issue on 2 different Mac mini's now (2011 and 2012 versions).  I may of found a fix so I'm posting here to hopefully help others.

     

    Basically there appears to be an HDMI copyright handshake issue that is causing the problem.  Both of my Mac Mini's would flicker every 5-6 seconds where the display would go black and then re-appear.  After talking to Apple Support the fix appeared to be doing an SMC reset as well as a PRAM reset.

     

    SMC reset

    http://support.apple.com/kb/HT3964

     

    PRAM reset

    http://support.apple.com/kb/HT1379

     

    This solution worked fine for my 2011 Mac Mini but not for the 2012 Mac mini.  I found that I had to completely disconnect the HDMI cable, and THEN do the 2 above resets.  THEN reconnect the HDMI cable.

     

    Hope this helps others!

     

     

    ***My Mac Mini's are connected to a home theatre setup and my displays are a Sharp 80"(LC-80LE632U) and a Mitibushi FD630U Projector.  After futher troubleshooting, Apple's HDMI handshake appears to have some issues with the Mitsubishi projector.  </quote>

  • calvol Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2012 1:07 PM (in response to --A--C--)

    Another good thread on the HDMI issue....

     

    http://forums.plexapp.com/index.php/topic/28792-screen-flicker-with-2011-mac-min i/

     

     

    User is offline   scottebarton@bellsouth.net http://forums.plexapp.com/public/style_images/plex/user_popup.png   Posts:  1     Joined: 16-March 12     Group: Members

     

    Posted 16 March 2012 - 04:46 PM
    I solved the issue for me with a different monitor first... I was using an ASUS AE278 27" LED first and it flickered and would go snowy randomly several times an hour... I had an Acer 23" LED and switch it and it worked great... However, after spending 300 dollars on the ASUS, I wanted to use it... I purchased an App called SwitchResX and it fixed all the problems for me... I checked the second 1920 X 1080 selection on the list of resolutions and all my problems went away....

    Scott

     

    0

    #

    #16User is offline   ProblematicLlama http://forums.plexapp.com/public/style_images/plex/user_popup.png   P

     

    Posted 16 March 2012 - 04:56 PM

    I used to have this problem when using 1080p over 50hz or 60hz - my amp/TV/something really hated it and flicked off every x seconds then back on again. I figured it was either an HDMI handshaking thing or I was trying to push through too much data. I upgraded my ATI graphics card drivers recently and it hasn't been a problem since.

     

  • Javier Chorrillos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 18, 2012 1:09 PM (in response to calvol)

    I own the 2011 MacMini also, and I never had that flickering problem at all.

    Only the 2012 MacMini has given me that problem. :(

  • --A--C-- Level 2 Level 2 (290 points)
    Currently Being Moderated
    Nov 18, 2012 2:14 PM (in response to Javier Chorrillos)

    the 2011 mac mini's definitely had video issues as well, HDMI handshake related, (inverted colors and drop-outs). A friend of mine had that problem.

    https://discussions.apple.com/thread/2600405?start=0&tstart=0

    https://discussions.apple.com/thread/3384157?start=0&tstart=0

  • BDAqua Level 10 Level 10 (114,800 points)
    Currently Being Moderated
    Nov 18, 2012 2:20 PM (in response to --A--C--)

    Great find/post, thanks!

  • chris.dangelo Calculating status...
    Currently Being Moderated
    Nov 18, 2012 10:05 PM (in response to KevCheng)

    Had it again today while playing team fortress 2 in os x.  Went black for maybe 2 seconds and came back on.  Out of the 5 times (maybe 6) this has happend 2 or 3 of the times have been while in a game.

  • BobH47 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 19, 2012 9:45 AM (in response to syhr)

    This is a really helpful post, thank you.

     

    Purchased Mini 5/11/12 from my local Apple Store. Monitor connected using supplied HDMI to DVI adapter.

     

    Quickly noted propensity for screen to briefly go black or for display to turn to grey background with 'snow'.

     

    Monday 12/11/12 reported to Apple Care: Agent did PRAM reset and asked me to monitor.

    Later that morning screen went blank again so phoned again. Coincidentally, during the call the screen went to 'snow'. Agent asked me to connect my HD TV via HDMI.

    No further problems that day but on Tuesday 13/11/12 TV screen blacked out twice briefly. I phoned Apple Care because I had now used two monitors, two cables and eliminated the adapter. He suggested that I exchange the machine at the shop.

    13/11/12 c1430 exchanged machine, told in store that they had not had any other minis returned. Took it home and, even whilst restoring Time Machine backup, the screen blanked to snow. Persevered that evening.

    14/11/12 Went on to Apple Support Communities and read your post amongst others. 1130, phoned store, told a manager would phone back. 1700 phoned store, told managers very busy, they would call me back.

    15/11/12 Still no call so phoned store again. I explained the problem to manager who asked what I would like to do. I explained that this is my main PC and that the Apple Support Community suggested that connecting using a Thunderbolt to DVI adapter should work (although it won't fix the HDMI issue). Manager agreed to send the adapter at no cost.

    16/11/12 The adapter arrived via TNT mid-morning and fitted. So-far, so good…….

     

    19/11/12 Still no further problems whilst using Thunderbolt to DVI. I phoned Apple Care to keep the case open because at the moment this is just a work-around and I may want to use the HDMI port in the future. Agent put me on to a manager who has taken the case personally and has just sent me an e-mail stating that he has escalated the case to their engineering department.

1 ... 18 19 20 21 22 ... 80 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (37)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.