Skip navigation

First USB port stops working after random time and won't work until I restart

1253 Views 26 Replies Latest reply: Jan 23, 2013 7:20 AM by ElectroSpyzz RSS
1 2 Previous Next
ElectroSpyzz Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 18, 2012 5:34 AM

Hey guys

I have this problem on my late 2011 Macbook Pro 13 inch,

It's been for a year already and it really freaks me out and drive me crazy

My first USB port next to the thunderbolt stops working after like 3 days, and it won't respond until I restart my computer or log off and log in again.

If I restart my computer, USB stops working after 3 days and won't respond until I restart

If I log off it works for like a couple of hours and then stops again


I have tried EVERYTHING, SMC reset - no luck, PRAM reset - same results, Upgraded to lion same results, Upgraded to mountain lion - SAME RESULT

And I can't take it to an apple store because I'm not from the US


I am 100% sure this is a software problem and I've seen here that many people have faced this problem

Please help, it really freaks me out

MacBook Pro, Mac OS X (10.6.8)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.