2 Replies Latest reply: Nov 20, 2012 8:59 PM by bobfromunionville
bobfromunionville Level 1 Level 1 (0 points)

I really liked the Magic Mouse for over a year, but now it's getting moody about it traverse response.   On a mousepad (good surface) it can be absurdly slow or not move at all in response to my hand.    If I move it to a hard (formica) surface it works normally but I don't want to use a hard surface for the sake of my wrist.   Battery at 80% today when it was acting up.   I tried rebooting the iMac, turning off and on the mouse, with no improvement.   Now, an hour later it's fine........for the time being.


Magic Mouse, Mac OS X (10.6.8)
  • 1. Re: Mouse traversing is occasionally slow / moody on a mousepad
    Kenneth E Level 1 Level 1 (10 points)

    I know this is going to sound strange but trust me it works and will not harm the optics like chemicals. I learned this from a fellow tec when i worked for the Kenwood service center some years ago and have used this method on CD players and optical mice over and over for years and it has yet to fail. Keep in mind that what you most likley have is fuzzy or fogged optics. The solution is "spit" and no i'm not kidding, assuming you're not into chewing tobacco or have a mouth full of tootsie rolls this method works fine. Find some of those little medical swabs at any pharmacy ( in a pinch a q tip will do but be carefull of the fuzz) turn the mouse over grab a swab and spit on the end and use it to clean the lens, then take a clean swab and polish the lenses gently. The reason you shouldn't use alcohol is that it attacks some plastics (ruining them) and (assuming it didn't melt it) it also attracts water vapor as it dries leaving a film on the lens.

    Good old spit, cheap, works well and is generally considered non toxic.... unless of course it's swallowed in small ammounts over a Looooong period of time.

    Hope this helps.

  • 2. Re: Mouse traversing is occasionally slow / moody on a mousepad
    bobfromunionville Level 1 Level 1 (0 points)

    Ken...  Perhaps it is that simple.   It's working fine right now so I'll wait until it screws up to try your solution.   Thanks.....