Skip navigation

"connection failed" mac app store

42587 Views 50 Replies Latest reply: Jan 28, 2014 7:50 PM by jameshgreggs RSS
  • Bart Gibb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 3, 2012 4:29 PM (in response to alfredo87)

    This "Connection failed" problem has been driving me crazy. Tried everything, but nothing worked...until this. Thank you! Now if I could just get Pages to work again...

  • anne-mettefromårhus c Calculating status...
    Currently Being Moderated
    Sep 9, 2012 6:45 AM (in response to alfredo87)

    This worked for me!! Mountain Lion is downloading !

  • jrusch1 Calculating status...
    Currently Being Moderated
    Sep 24, 2012 4:42 PM (in response to realtorjosh)

    Hi. Same problem of no App Store and other "trust" issues, but a combination of things worked to clear it up.


    First I tried the blog post instructions referenced above but they didn't work. Then I tried setting my date and time prefs to automatically update, as mentioned (it had been unchecked), but that didn't work either. I then went at the Keychain Access certificate approach one more time. What I did was not mentioned in the blog instructions, but someone else had mentioned System Roots, so I clicked on System Roots in the left hand column of KeyChain Access, then Certificates below that. I *then* noticed some blue plusses on some certificates I hadn't noticed before, and cleaned them all up (Set them to default, per the instructions). I had thought I had got them all, but I hadn't done the System Roots ones, because they're not mentioned by the blog.


    This worked at last. I don't know whether the date thing mattered in conjunction with the rest, but it didn't hurt. Thanks everyone for contibuting.


    Safari now presents secure websites correctly and Mountain Lion is now downloading!

  • Plain Stone Calculating status...
    Currently Being Moderated
    Sep 25, 2012 7:28 PM (in response to jrusch1)

    Hi, I have had the same issue since Lion. I couldn't upgrade to Mt. Lion. I upgraded after a clean install and it worked until I migrated my applicaitons. Long story... Anyway, I saw your post and when I went into the keychain>system roots/certificates, I also found about 8 blue + certificates. However, when I attempted to change them to "system default" I found they wouldn't "stick". When I'd return and look at them, they had all reverted to "always trust", as before. So then, upon the kind suggestion of my new "best friend" at Apple tech support, we changed them to "never trust". The certificate would change to red, and when I reopened each certificate, they had stayed.  Then when I changed them back to "system default" they remained. I rebooted and YEA! now the app store works and I'm downloading updates!!

  • yma Calculating status...
    Currently Being Moderated
    Oct 3, 2012 8:05 PM (in response to jrusch1)

    Thanks for this!  None of the other solutions worked for me either, but cleaning up the certificates in system roots did.  Yay!

  • Saltykov Calculating status...
    Currently Being Moderated
    Oct 6, 2012 10:36 AM (in response to Plain Stone)

    After trying some other suggestions to solve the connection problem, a couple of hours with Apple and a reinstall of system software, I finally came across your post. And it worked!  Thanks.

  • amphitryon Calculating status...
    Currently Being Moderated
    Oct 11, 2012 12:36 PM (in response to alfredo87)

    This worked for me! Thank you!

  • rsnunes Calculating status...
    Currently Being Moderated
    Nov 10, 2012 6:08 AM (in response to alfredo87)

    This method solved my issue!


    Thank you



    from another thread in this forum.

    Now to do this follow this:


    1. Open Key chain access in the Utilities folder
    2. Search for "class 3 public" without quotes
    3. select all the certificates on the list by clicking and holding the cmd key (apple key)
    4. right click selection and choose get info
    5. in the windows that open go one-by-one and click on Trust at the top of the list
    6. From the drop down menu choose "Always trust"
    7. Close window and enter your password if asked
    8. Repeat for all certificates
    9. Close Key Chain Access
  • jmelowry Calculating status...
    Currently Being Moderated
    Nov 15, 2012 12:19 PM (in response to flynnd27)

    Toggling "set date and time automatically" did the trick for me.

  • slazio Calculating status...
    Currently Being Moderated
    Nov 19, 2012 1:25 PM (in response to remittancegirl)

    Could NOT figure this issue out on my iMac, but remittancegirl's solution worked like a charm.  Thanks!

  • kylie1981 Calculating status...
    Currently Being Moderated
    Dec 27, 2012 11:06 PM (in response to realtorjosh)

    Yep, I got a new macbook air... my pro works fine..... couldn't connect to itunes store or app store.... tried everything else (as I couldn't go elsewhere to try another network) nothing helped, but then der I tried connecting using my iphone personal hotspot and it worked! Disconnected hotspot went back to home network and walla it SEEMS to be fine now???? Very strange! I've spent hours trying to fix it!

  • Bigmac111 Calculating status...
    Currently Being Moderated
    Dec 28, 2012 8:20 PM (in response to jrusch1)

    Worked like a charm.  Thanks!

  • 7ecapilot Calculating status...
    Currently Being Moderated
    Jan 29, 2013 8:47 PM (in response to alfredo87)

    alfredo87, thank you very much. Changing the Class 3 certificates to Always Trust fixed this issue for me. I had deleted all of my certificates and then began manually accepting them when I returned to certain websites (financial, entertainment, etc.). I have also been having a little trouble with the iTunes Store also. So, this seems to have fixed both problems. Wow! Now I have that iPhoto and XCode updates. Nice!

  • Hadil3 Calculating status...
    Currently Being Moderated
    Feb 14, 2013 3:41 PM (in response to Carolyn Samit)



More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.