Skip navigation

HD corrupt, disk utility can't repair it. can't boot.

1158 Views 3 Replies Latest reply: Nov 20, 2012 7:06 PM by BDAqua RSS
Kreynor Calculating status...
Currently Being Moderated
Nov 19, 2012 3:50 PM

I have a early 2009 iMac with the latest Mountain Lion update (did the last update two days ago). My HD has two partitions: one for os x and one for windows with bootcamp. I'm curently writing using the windows partition where everything works fine.


Yesterday I started my mac on X. Same gray loading screen but it had a small bar on the bottom. When the bar reached nearly half, the mac shut down. This happens now every time I try to start the mac on X and if I keep pressed ALT to choose which partition to use, the one for X is called "EFI Boot".


I booted in recovery and later using a snow leopard dvd, and I used disk utility. It said "invalid index key" and that the volume needed to be repaired, but disk utility couldn't repair it.


I tried rEFIt to check if there were problems with the partitions: all ok.

I tried the fsck console command: all ok.


Now I'm in the windows partiton and if I navigate through the X partition (I have MacDrive installed) I see that some files are missing. I'm sure they should be there, but they're nowhere to be found.

Of course MacDrive tells me that the volume is damaged, etc...


What can I do?

iMac, OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 Level 10 (114,825 points)

    What files are missing?


    Might try this...


    Just recently I ran into a problem when I tried to Verify my hard disk and when it tried to verify the catalog, it responded "Invalid sibling link." Repair Disk didn't work. I searched the web and Apple's site, and couldn't find anything useful except to buy DiskWarrior or reformat the drive. Knowing that OS X is built on Unix gave me a few clues on how to proceed. The solution is pretty simple:

        1.    Boot off the OS X CD (reboot, hold C while booting).

        2.    The installer will load up, go to Utilities in the menu and run Terminal.

        3.    Type df and look for the drive that has your Mac system mounted---you'll have to unmount this. On my MacBook Pro, it was /dev/disk0s2.

        4.    Type umount /dev/disk0s2, replacing disk0s2 with whatever disk your OS lives on.

        5.    Type fsck_hfs -r /dev/disk0s2. If you umounted the wrong thing, it will complain that you can't repair a mounted drive. Go back and umount the right thing and repeat this step.

    Just for fun, you might want to run another fsck_hfs on your disk (use the -f option because your drive is probably journaled). Hope this helps someone so they don't buy a program that's going to do pretty much what we did with fsck_hfs, and so they don't waste time searching for an answer to no avail. By the way, TechTool Deluxe (3.1.1) didn't find the Catalog problem for some reason (you'll have this on a CD if you have AppleCare), which is why I resorted to fsck.


  • BDAqua Level 10 Level 10 (114,825 points)

    OK, good luck!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.