Skip navigation

Can't print from a windows pc to network printer

392 Views 11 Replies Latest reply: Nov 21, 2012 3:25 AM by LousyFool RSS
Detective445 Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 18, 2012 10:45 AM

I am having a network printer problem.

I have a Canon printer plugged into the usb port of my Mac-Mini.  I can print fine from the Mac to the printer.  I have network sharing enabled for the printer.

 

I have a Dell PC connected to an Airport Express via internet cable as part of my network.

I have bonjour installed on the Dell

Bonjour can see the networked canon printer and will install it as the default printer for the Dell PC.

However, I can not print from the Dell unless I have the wrong printer driver (an HP driver) installed.  As long as the wrong driver is installed I can print the first page of a document only.

If I install the correct Canon driver, the printer ceases to function.

 

I tried connecting the printer to the airport express via usb.  Once I did this, I was able to print from the Dell pc with no problem using the correct driver.  But then, I could no longer print from the Mac-mini via the Airport Express connected printer.  The Mac could see the printer and identify that it was connected via Airport.  And the Mac will allow me to connect to the Airport connected printer .  But as soon as I trie to print something from the Mac, it fails and gives an error message or pauses and says the drivers may not be correct.

 

Can anyone help me with this issue?

Mac mini, Mac OS X (10.7.5)
  • LousyFool Level 4 Level 4 (2,640 points)

    <Edited>

     

    Okay, you tried two different setups. Maybe you should reset the printer systems on both Mac and PC, then set it up the one way you prefer and with the correct Canon printer driver, then post the exact error message you're getting?

  • LousyFool Level 4 Level 4 (2,640 points)

    Detective445 wrote:

     

    I believe that there may not be a solution to this because the printer will only recognize one set of drivers.  Since one set of drivers is for the Mac and one set is for a PC It will only work with one machine or the other.

     

    Then you should be able to print from the Mini after resetting the printer, e.g. by turning it off and back on after a short while. But it sounds as if this won't help either, and to be frank, it's not an "acceptable" explanation, either...

     

    So, what's the error message? Unless known, we can only keep guessing:

     

    You've reset the printer system in the Mini? Eventually consider deleting the Canon drivers manually afterwards, and only then add the printer again and re-install its software.

     

    If that doesn't help either, the issue must be a communication problem, meaning I'd recommend to double-/triple-check all comm-related things as well.

  • LousyFool Level 4 Level 4 (2,640 points)

    It's simple: if a print job gets stuck, you'll have the printer icon in the dock with a badge attached to it. A click on it will open it and tell you the problem...

  • LousyFool Level 4 Level 4 (2,640 points)

    Detective445 wrote:

     

    Canon UFR II Printer Driver.  Cannot communicate with the printer, or the printer is not supported.  If the printer is supported, check the printer connection and add it again, then start Printer Utility to get the printer information.

     

    Well, I guess this is the answer. In combination with you saying that it works fine with the Mini when directly connected to it, and the Dell being able to use it when the printer is hanging off the AE, I guess you do have a comm problem in between the Mini and the printer... and if it's the driver having trouble with the network.

     

    Mind sharing which printer model it is?

  • LousyFool Level 4 Level 4 (2,640 points)

    Hmm, no objections if you use driver v2.41...

     

    All pointers towards communication...

     

    BTW, can you use the scanner function via AE?

  • LousyFool Level 4 Level 4 (2,640 points)

    Good.

     

    However, as far as printing is concerned in your preferred setup it looks like you're out of luck: when googling "mf4350d network" or "mf4350d airport", what you get is trouble reports all the way to statements that this unit isn't network-ready, at least not over devices such as Airport Express, or as a shared printer on a Mac, for that matter. If you haven't done yet, out of curiosity I looked up quite a few forum posts, and there is not a single solution for your setup I could find.

     

    Unusual for Apple/Canon, I'd say, but there you go. Sorry.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.