Skip navigation

iPhoto displays RAW photos with a dark green cast

337 Views 3 Replies Latest reply: Nov 19, 2012 5:43 PM by whortman RSS
whortman Calculating status...
Currently Being Moderated
Nov 11, 2012 5:04 PM

Tonight I imported photos into iPhoto from a Canon Rebel T2i, and the large previews look fine the first time I scan through them. But then if I run through them again some (not all) end up with what looks like a dark green overlay on them.

 

I've been using this camera and iPhoto for a couple of years now. This is a first. I'm shooting RAW (CR2), so I'm guessing the iPhoto RAW processor got borked in an update recently.

 

Saw similar issues in the forum from people using Aperture. Tried a few of their suggestions to no avail. Anyone else running into this with iPhoto?

iPhoto '11, OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,700 points)
    Currently Being Moderated
    Nov 12, 2012 4:56 PM (in response to whortman)

    Have you enabled "highlight tone priority" in your Canon camera? The mac raw conversion does not handle this feature, and so the camera generated jpegs will reflect the highlight tone priority, but the developed raw image will not.

     

    If you have been using this feature, turn it off and try again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.