Skip navigation

Services disappear...

795 Views 23 Replies Latest reply: Dec 8, 2012 2:30 PM by felix47 RSS
  • Linc Davis Level 10 Level 10 (107,665 points)
    Currently Being Moderated
    Nov 20, 2012 8:06 AM (in response to felix47)

    Back up all data.

     

    If you have more than one user account, you must be logged in as an administrator to carry out these instructions.

     

    Launch the Terminal application.

     

    Triple-click the line below to select it, then drag or copy into the Terminal window — do not type — and press return:

     

    sudo fs_usage -w -f pathname pbs

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning. If you don’t have a login password, you’ll need to set one before you can run the command.

     

    Let the command run for about 20 seconds, then press the key combination command-period to stop it.

     

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Linc Davis Level 10 Level 10 (107,665 points)
    Currently Being Moderated
    Nov 20, 2012 10:47 AM (in response to felix47)

    You didn't enter the command correctly. Please review the instructions and try again. If it still doesn't work, post a screenshot of the Terminal window showing what you did.

  • Linc Davis Level 10 Level 10 (107,665 points)
    Currently Being Moderated
    Nov 20, 2012 11:35 AM (in response to felix47)

    Please enter the following command in the Terminal window as before (no typing) and post the output:

     

    md5 /System/Library/CoreServices/com.apple.NSServicesRestrictions.plist; ls -l $_
    
  • Linc Davis Level 10 Level 10 (107,665 points)
    Currently Being Moderated
    Nov 20, 2012 1:37 PM (in response to felix47)

    That file is OK, but you have a corrupt file somewhere. The process pbs, which generates the Services menu, is crashing. That could be because of system corruption, or because it's choking on a service provided by one of your third-party applications.

     

    I would start by reinstalling OS X in Recovery mode, not because it's more likely to work, but because it's relatively easy to do.

     

    If reinstalling doesn't work, then you have a difficult problem. The best way to proceed, I think, would be to remove all your third-party applications and anything in the folder /Library/Services. At that point pbs should stop crashing. Put the items back piecewise until you find the culprit. I suggest you start with "CopyPaste Pro," because one of its files appears in the fs_usage output. It may not be the right one, however.

     

    If you know that an application doesn't provide services, you can skip it.

     

    Before you start this time-consuming task, make sure that the information you provided earlier in Steps 1 and 2 is accurate. If not, you're on a completely wrong track.

     

    That's all I can offer.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.