13 Replies Latest reply: Mar 15, 2013 8:43 AM by aninterestedparty
notechhouston Level 1 Level 1 (0 points)

Why do birthdays show up twice in ical?

  • 1. Re: why do birthdays show up twice in ical
    rkaufmann87 Level 8 Level 8 (42,145 points)

    Probably because you have both iCloud and On my Mac selected in the Calendars in iCal, you need to choose one or the other. If you have multiple Macs or IOS devices then just choose iCloud. 

  • 2. Re: why do birthdays show up twice in ical
    Anon M Level 1 Level 1 (0 points)

    I have the same problem, and I have only "iCloud" selected... so why does this still happen?

  • 3. Re: why do birthdays show up twice in ical
    hendo2026 Level 1 Level 1 (0 points)

    i have also had this issue and i have resolved on my machine as follows:

     

    background:

    i have multiple devices all configured with icloud - hence, all contacts, mail and calendar items are synchornised across each device via icloud. i am running mountain lion.

     

    my issue:

    i had one machine - my Mac Pro - with duplicate birthdays loaded into ical - the other machines only showed single birthdays. i tried turning off the "show birthdays calendar" option in ical preferences, letting it synch, then turning back on. this didn't help.

     

    i then checked the source of the information - contacts. i found when i checked the "All Contacts" folder i had duplicate contacts - icloud and i also had "on my mac" contacts as well on this machine. i did not have this on any other machine. this was the issue as ical was reading both sets of contacts.

     

    how to solve:

    i needed to remove the "on my mac" folder from contacts. i did this by switching off icloud contacts in "system preferences", it then prompts you to "delete from mac" to remove the copy of icloud contacts. i selected "delete from mac". this removed all contacts from the machine (i.e. my contacts on my Mac Pro were completely empty). remember i still had the contacts in icloud to retrieve later.

     

    next step, you need to setup contacts again to read from icloud. go to "system preferences" again, go to icloud and click to "contacts" to enable icloud for contacts again. icloud will start to synch to your contacts. open contacts to check. you should see only:

    icloud

    - All Contacts

    Smart Groups

    - Last Import

     

    there is no "On My Mac" folder and thus no duplicates so the fix worked. i then only had single birthdays loaded.

     

    if you only have a single machine then do a backup of your contacts before doing this to ensure you don't lose your contacts during this process. as long as you have setup icloud and have synched then should be fine though.

  • 4. Re: why do birthdays show up twice in ical
    astitchintime Level 1 Level 1 (0 points)

    Thank you Hendo,

     

    This solution partially worked, in address book now i have on icloud/all contacts and smart groups/last import as you suggest.

     

    BUT.... instead of having only one copy of the birthday what I have now is one copy that says eg "Kate's Birthday" and one copy that just says "Birthday".

     

    So every birthday still has two copies it's just that one of them doesn't tell you whose birthday???

     

    Weird.

    Any more suggestions?

  • 5. Re: why do birthdays show up twice in ical
    hendo2026 Level 1 Level 1 (0 points)

    do both of these appear in the "subscriptions" list in your calendar?

     

    if so, you can just delete "kates birthdays" from your calendar leaving only "birthdays". are you sure that "kates birthdays" is not another shared calendar from someone else on the network?

  • 6. Re: why do birthdays show up twice in ical
    rkaufmann87 Level 8 Level 8 (42,145 points)

    hendo26 is on the correct path, in iCal in the upper left it will show Calendars. You have multiple calendars selected that have duplicates. You need to uncheck the boxes that create duplicates for you. For example if you have a calendar in iCloud called Home and you also choose another calendar that has duplicate events (in your case birthdays) then you will have duplicate entries in iCal.

  • 7. Re: why do birthdays show up twice in ical
    brendafromdidsbury Level 1 Level 1 (25 points)

    Do you have facebook?  Is the facebook 'integration' active?  If you click, in iCal, on the person's b'day, then either the 'url' or 'show in contacts' and check the email for that birthday contact.  If it's a facebook email address then it's not a duplicate calendar.  The 'birthday' calendar picks up birthdays from your contacts.  Open Contacts and check the 'Groups'.  (View, Groups).  If you have a group for Facebook contacts then that is why you have dupes.  Calendar is picking up b'days from two duplicate contact birthdays - one from your own contacts and one from Facebook contacts.

     

    Brenda

  • 8. Re: why do birthdays show up twice in ical
    astitchintime Level 1 Level 1 (0 points)

    Thank you all three of you for your solutions.

     

    The problem seemed to actually resolve itself, when I opened up ical today the second no name birthdays are gone???? go figure. 

     

    Just of interest though I do not have facebook integration on and I only have one calendar with birthdays in it in the drop down from the calendars button on top left.  When i unclicked the birthday calendar both entries disappeared.  I also tried to delete the extra birthday by clicking directly on it but there is no edit button and the message comes up stating that I cannot change or delete entries in the birthdays calendar  and tells me to go to address book to do it???? So who knows but it seems to be fixed anyways.

     

    Thanks

  • 9. Re: why do birthdays show up twice in ical
    dorosbourne Level 1 Level 1 (0 points)

    A big thanks to you.  Seemed leery of deleted all on my Mac, but that is what was needed.  People need to follow your directions exactly, and it will work.

  • 10. Re: why do birthdays show up twice in ical
    dorosbourne Level 1 Level 1 (0 points)

    How do I give you a green checkmark that this solved my problem?

  • 11. Re: why do birthdays show up twice in ical
    brendafromdidsbury Level 1 Level 1 (25 points)

    "You can only award points in threads you create and mark as being questions, and you can only award two Helpful ratings and one Solved in each thread."

     

    It's not clear from your post which person you want to thank.  I'm sure posting your gratitude is much appreciated. If you look at the original question posed by 'notechhouston' I believe it is that poster who originated the question that would be the one that can award 'points'.  As it often happens, a variety of people tack on, who have the same or similar questions, and the final solution(s) may be directed to the extra passengers that jump on board.

     

    These forums are great but are not always easy to navigate. :-)

     

    Brenda

  • 12. Re: why do birthdays show up twice in ical
    kinseve Level 1 Level 1 (0 points)

    To fix the duplicate birthday issue on my Mac (OSX 10.8) I performed the following steps. From the systems preferences panel, go to icloud, deselect the box next to contacts, wait a moment, reselect the contacts box. Open calendar and view the results.

  • 13. Re: why do birthdays show up twice in ical
    aninterestedparty Level 1 Level 1 (10 points)

    I had the same problem; every birthday, for example 'Kate's birhtday' had a duplicate entry just called 'Birthday'.

    I followed Hendo2026's solution with one extra step

    1.     Go to system preferences and open iCloud preferences

    2.     De-select Contacts and choose the option delete all contacts from my Mac [sounds a bit extreme]

    3.     The re-selected Contacts checkbox and after a scary moment or two all my contacts re-appeared as synced wiht iCloud

    BUT I still had the duplicate birthday entries, so figuring this was a problem on my Mac (I didn't have duplicates on my iPhone for example, which is synced via iCloud) I repeated the steps above but with the Calendars and Reminders checkbox

    1.     Go to system preferences and open iCloud preferences

    2.     De-select Calendars and Reminders and choose the option delete all records from my Mac

    3.     The re-selected Calendars and Reminders checkbox and after gradually all my calendar entries re-appeared as synced wiht iCloud, and the duplicate birthdays disappeared, although oddly not immediately.

    Maybe the same would have happened as it did for astitchintime anyway, but this extra step seemed to be required for me.