Skip navigation

iPhoto disappeared

1341 Views 5 Replies Latest reply: Nov 21, 2012 7:02 PM by runner74 RSS
Stu B. Calculating status...
Currently Being Moderated
Apr 13, 2011 7:19 PM
The iPhoto icon appears on my desktop but the program won't open. I've tried to launch it several different ways but I get the following error message:

Unable to launch iPhoto (null) could not be launched because an error occured
(** -[NSCFDictionarysetObject:forkey:] :attempt to insert nil value (key: -NSTaskExecutable

I have no idea what this means. I was able to find via iPhoto Library Manager, all of my photos so I know they're still on the computer. How do I get theiPhoto program back and how do I get the photos back into the program???
iMac, Mac OS X (10.6.7)
  • Terence Devlin Level 10 Level 10 (121,655 points)
    Currently Being Moderated
    Apr 13, 2011 10:42 PM (in response to Stu B.)
    To re-install iPhoto

    1. Put the in the trash (Drag it from your Applications Folder to the trash)

    2a: On 10.5: Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

    2b: On 10.6: Those receipts may be found as follows: In the Finder use the Go menu and select Go To Folder. In the resulting window type


    A Finder Window will open at that location and you can remove the iPhoto pkg files.

    3. Re-install.

    If you purchased an iLife Disk, then iPhoto is on it.

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

    If you purchased it on the App Store you can find it in your Purchases List.


    MacBook Pro 15 2.4 i5 / iMac 20" 2.66 C2D, Mac OS X (10.6), 8 gig RAM/ 4 gig RAM
  • LarryHN Level 9 Level 9 (54,845 points)
    Currently Being Moderated
    Apr 14, 2011 10:33 PM (in response to Stu B.)
    Your choices are as stated - wither install from the original restore disks using the install bundled software only option which installs only the selected software - or install from a purchased upgrade disk or a purchased apps store download

    If done correctly none of these will cause your to "lose everything" - or even to lose anything

    But of course you should always have a backup - computers, software and people do fail

    3.33 GHz Intel Core 2 Duo 27" iMac, Mac OS X (10.6.6), iPhoto 9.1.1, Time Capsule, 2 TB OWC EHD, Sony DSC-HX5 camera
  • birdy176 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 20, 2012 7:50 PM (in response to LarryHN)



    Forgive me for latching onto the previous poster's query with the identical problem we have been discussing.


    I spent some 4 hours reinstalling Leopard 10.5 from my original disks which did not have a trace of anything called "restore disc". I then used my store bought Snow Leopard disks to upgrade my system to 10.6.3 and the online Update Service to bring it to v. 10.6.8.


    The iPhoto app or program was not included and rebuilding of the Library as per a link I saw earlier did not work since it involves holding down the OPT-CMD keys and then opening iPhoto.


    I have no iPhoto icon to hold down. When I did have it (earlier today) it did not function - even after re-installing everything with discs supplied by Apple and purchasing the Snow Leopard upgrade.


    I had taken camera pictures of the progressive window display to show you that I could not see iPhoto in any of the images but I could not attach them because Picasa converted them to *png files apparently not accepted in this forum.


    Time Machine also let me down in that it did not put my system back as advertised despite the fact that it lives on a dedicated external drive while my movies and photos are saved on another one.


    I am using Safari for this post although I am not familiar with it. My first version of this post was lost when I looked for the notification button at the very top.

  • runner74 Calculating status...
    Currently Being Moderated
    Nov 21, 2012 7:02 PM (in response to birdy176)

    My i-photo icon is there when I  use Finder.  The icon does not work.  The isntructions above are too hard for the 74 year old brain.  I suppose I need to take it into the Apple shop.  I was fascinated to find this Web site or whatever it is called.


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.