Skip navigation

iBooks 3 read-aloud timings broken

980 Views 7 Replies Latest reply: Nov 22, 2012 1:47 PM by tkchung RSS
gadgetmax Level 1 Level 1 (5 points)
Currently Being Moderated
Nov 7, 2012 2:57 PM

It seems that read-aloud that worked great with iBooks 2 is now broken in iBooks 3. SMIL timings generated by Audacity now fail to highlight some words--the same words every time. We find that if we play with the timings we can make the problem move around but we don't yet have a perfect solution.

 

Has anyone else encountered this problem?

  • tkchung Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2012 12:15 PM (in response to gadgetmax)

    Hi gadgetmax, yup I ran into this problem too.  I ended up having to create a text-only version of my fixed format epub just so I could test all the narration thoroughly, tweaking some of the clipstarts by adding a few milliseconds until the word lit up, to ensure everything was highlighting. Then throwing all the smils back into my original epub and rebundling. A perfectly good waste of a weekend.  Pretty frustrating, seems like the new iBooks was a bit rushed getting out.

     

    Cheers,

    tkc

  • JudithT Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 21, 2012 10:18 AM (in response to gadgetmax)

    iBooks 3 works just fine for my Children's Book.  What I did in Audacity was highlight my first word, made a label.  Then I highlighted my second word up until I saw the yellow line and made a label for my second word.  I did this technique for all my words.

     

    When doing the .smil file there were no gaps (seconds) in my recording.  For instance:

     

    clipBegin="0.000000s"clipEnd="0.766258s"
    clipBegin="0.766258s"clipEnd="1.033288s"

     

    clipBegin="1.033288s"                  clipEnd="1.207438s"

     

    By having the clip end and begin for next word, iBooks 3 knows where the next word starts and will highlight it.

     

    Message was edited by: JudithT in order to show clip beginning and ending - html symbols would not show in my reply.

  • tkchung Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2012 12:49 PM (in response to JudithT)

    Hi JudithT, it's very odd.  That was how all my words were set up as well i.e. no gaps.  One thing I could think of which may be different, is that I added a spacer timing of about .3 seconds at the beginning and end of each page.  I had no problem in previous version of iBooks with that setup however.  It was only until I updated to iBooks3 that it started happening, and there seemed to be no pattern to it that I could detect.

     

    Regards,

    Tim

  • JudithT Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 21, 2012 1:07 PM (in response to tkchung)

    What I did when I wanted extra timing was to add silence of 2 seconds and include it in my first Labeled word.  And if I wanted extra time at the end, I had extra silence at the end of the audio recording and then included it with the last word on my .smil file.

     

    You might try that and see if you get a more consistent result.

     

    I have CSS animation in my Children's Book and only words on my first .xhtml page of a two page spread.  The animation happened on the second .xhtml page so I added enough seconds to the first page .smil file to have it keep going until the animation played out on the second page.  It worked very well.  And the page will not automatically flip until the .smil file tells it to be done.

     

    Tim, after re-reading what you wrote about spacer timing, we might be saying the same thing.  I have an Original iPad I'm testing mine on but I'm pretty sure I have the new iBooks 3 on it.

     

    I do know when I was originally testing the read aloud for my eBook, it would skip a word.  Usually when I closed and reopened the book on my iPad, it would resolve itself.  Other than what I mentioned, I have no other recommendations.

     

    Message was edited by: JudithT

     

    Message was edited by: JudithT

  • tkchung Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2012 3:55 PM (in response to JudithT)

    Hi Judith, I noticed you mentioned you had all your text on only one side of the two-page spread.  I had my text on both sides of a two-page spread so maybe that had something to do with it.  Although if I remember correctly, the unhighlighting occurred randomly on either side of the page.  Other than this, and I didn't have any CSS animation, I can't really see a difference.  I'm going to do a test and remove my text from one side of the spread, see if that changes anything, will let you know how I get on.

  • JudithT Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 21, 2012 5:02 PM (in response to tkchung)

    Tim,

     

    Well no, what I had was on a few pages only text on one side.  On others, I had text on both sides of a two page spread.  But I still had silence on both sides of 2 seconds or more depending on my animation.

  • tkchung Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2012 1:47 PM (in response to JudithT)

    I had a look at the Apple's own Fixed Layout Example 3.0.  On page 5, the 2nd 'shall' fails to highlight.  I unzipped the .epub and found this is word84.  The word prior to it has a clipEnd of 0:00:32.233 which is exactly the same as the clipStart for word84.  Thus no gaps, yet it is failing to highlight.  There's no explicit pause stated at the start or end of the .smil either.  It seems to be quite random that this is happening.  Note this is the only word in the entire epub which is not highlighting, at least as far as I could tell.  So I would think it is entirely possible that you could end up with an epub with no problems if you are lucky enough, but this is definitely a bug in iBooks 3.0.  I would just say test your read-alouds thoroughly and tweak your clipStarts where necessary, until this problem is fixed by Apple.

     

    Regards,

    Tim

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.