Skip navigation

"Unable to write to the last block of the device"

87837 Views 38 Replies Latest reply: Jan 6, 2014 2:30 PM by Afrit RSS
  • geryd Level 1 Level 1 (0 points)

    I had the same problem with my old internal disk which used to hold my home folder.

    After replacing it with a new one I hooked it up to a SATA to USB 3.0 and wanted to format

    the drive.  I first got an error that the drive could not be unmounted.

     

    After force unmounting the drive with terminal I got the famous "could not write to last block" error.

     

    I tried formatting on my macbook pro, 2 imac's and a windows 7 laptop,

    all with no succes.

     

    What did the trick for me was breaking open my external harddrive and hook up the drive in there.

    Connect it with the firewire 800 cable to my macbook pro and formatted the drive with no prob.

     

    apparently for my drive it was a USB conflict...

  • MaximumColor Level 1 Level 1 (0 points)

    I was able to salvage two drives today using FireWire 800.

     

    Both drives failed during a change from Apple partiton to GUID using USB. No matter how I tried I couldn't get past the Failed To Write Last Block message. (or something like that)

     

    I pulled the drive(s) from the external USB drive and plugged  into a FireWire drive and Presto no problem creating a Bootable Intel Partition. GUID (Using Disk Utility in Lion) The drives now work in the USB enclosures.

     

    Some drives may fail due to mechanical failure but many are disabled due to some kind of bug. I am  quite sure about this.

     

    Good luck, I hope some good Hard Drives can be salvaged using this method.

  • tcpeng Level 1 Level 1 (0 points)

    This was the most effective solution when I encountered the "unable to write to the last block" error.  Thanks.

  • Cbjornsen Level 1 Level 1 (0 points)

    I just encountered this exact same error with my external WD HDD, after trying to erase it with Disk Utility.

     

    Spent the last 4 hours trying everything to make it work, Terminal, Recovery Boot, Disk Utility, Different Mac etc.

     

    At last I fell upon another thread about the POSIX input/output error. In this thread it was suggested to try GPARTED Live or iPartition.

     

    So that's exactly what I did. I got a hold of the latest version of iPartition (I know it's a quite expensive app, but it's got a demo version, and can be acquired from other sources as well )

     

    Anyway, iPartition finally enabled me to fully erase my external drive, add a new partition and now I can use the HDD for TimeMachine again.

     

    I had a faulty flash drive which iPartition succesfully reformated and it's now fully working.

     

    Friggin brilliant tool. I can only recommend anyone with the POSIX: INPUT/OUTPUT error, or the above stated "Unable to write to last block of the device" error to try it out. Helped me a lot, and saved me a lot of time and money.

  • Arpamac Level 1 Level 1 (0 points)

    I saw somebody else post this and I tried it and it worked. Run Disk Utility from the Recovery Partition. Easy.

     

    For step-by-step:

    - Reboot into Recovery Partition (hold option when restarting).

    - run Disk Utility

      - Format drive like you normally would

    -  Boot back into regular partition

     

    I don't know why Disk Utility didn't work from normal startup.

     

    I don't know if this will solve your problem, but it worked for me. And I think I tried every other suggestion before doing this. My setup:

    - Internal drive is a 4TB Seagate ST4000DX000 pulled out of a Seagate Backup+ USB3 case

      - Connection is via one of the "extra" SATA ports on 2008 Mac Pro

      - Mac OS X 10.8.4

  • Fred Wu Level 1 Level 1 (55 points)

    Hey, Cbjornsen - I got mine to work the same way, almost.  I went to zero out an old 40gb IDE laptop drive that I hadn't been using for a while and partway through, it gave me an error.  From that point on, I just kept getting the "unable to write to the last block of the device" error.  I could erase the Volume in Terminal and get it to mount as an unformatted drive, but every time I tried to format it, whether in Terminal or from the Recovery Partition or from my regular Mountain Lion install, it gave the "unable to write to the last block of the device" error again and I had to re-erase the Volume in Terminal.  Finally, I went with iPartition.  Kept getting an error trying to create an Apple or GUID partition map, but it worked when I chose the Master Boot Record.  Then I formatted as a FAT32 volume, and now it works fine.  I was going to try reformatting now that it's working as Mac OS Extended, but thought better of it and just quit while I was ahead.

  • Paul Kleeberg Level 1 Level 1 (40 points)
    Currently Being Moderated
    Nov 2, 2013 11:49 AM (in response to Cbjornsen)

    Three different USB devices on 2 different 10.9 Macs.  In the process of extended "writes" of data (1 or more hours) the devices work for a while then I get the message that the computer lost the connection with the device.  Now, when I attempt to mount the device, I get the message: "Unable to write to the last block of the device"  Tried several tricks including a demo version of iPartition.  I may continue to try to mount the device but I am concerned that this error will keep occuring.  Appears to happen when there is a long write process to the device.  Same message with 2 USB flash drives (one brand new) and one 2T Segate external USB drive.  Very odd!  One computer is a brand new Powerbook Pro with USB3 and the other is an older 27" iMac with USB2.

  • Paul Kleeberg Level 1 Level 1 (40 points)

    After being on the phone with level 2 technical support, we turned off hard disk sleep, power nap and computer sleep on both devices and a 4 hour write went with out problems.  Now if I could just get my 2TB drive back!  Will try the genious bar after I return from a trip.  Tech support said the soon to be released OS update will fix this.

  • Afrit Level 1 Level 1 (0 points)

    Awesome! This definitely helped ! Nothing else needs to be done. Quick and Easy! Thanks !

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.