Skip navigation

Raw Images (Nikon D700 NEFs) suddenly turn unsupported

1503 Views 34 Replies Latest reply: Nov 30, 2012 4:24 PM by Jerry Dalton1 RSS
1 2 3 Previous Next
FrankieGans Calculating status...
Currently Being Moderated
Nov 22, 2012 3:34 PM

Hi there,

for some of my managed Nikon D700 NEFs I start geeting an 'unsupported image format' error. I worked with those files a couple of months ago and everything was fine, no errors. So, the problem must have came up recently. The files wont show up in Preview neither but open fine in Capture NX2 which brings me to the assumption, that it is an OS X raw compatability issue.

I browsed through the related discussions but couldn't find a way that resolved the problem. What puzzles me is the fact, that obviously only few people are experiencing similar issues. I'm afraid, that something might be "broken" in my system installation. To double check this I would like to provide one of my unrecognized NEF files:


If this file works for you, it's not an Aperture issue, but a single problem on my (few) machine(s). The answer to this would be of great help in finding the right fix. Any feedback is highly appreciated! Thanks!





iMac 24", 2.4 GHz Intel Core 2 Duo, 4 GB

OS X 10.8.2 (12C60)

Aperture 3.4.3

Raw 4.01

  • Aye Es Oh Level 2 Level 2 (330 points)

    I do indeed open the linked NEF without any problems in Preview and Aperture. Leonie just replied to a similar thread with this suggestion to re-register the CoreTypes Bundle. It's worth a shot, let us know if it helps.

  • Jerry Dalton1 Level 1 Level 1 (10 points)

    I was able to view the Nikon NEF photo in Preview and also import it into Aperture and view it.  Nice pic. Looks cold. I'm running OS 10.8.2 and Aperture 3.4.3 on a 2008 MacBookPro.

  • léonie Level 8 Level 8 (46,390 points)


    I just downloaded your image file - I have the same Aperture version as you, also the same system version, and Aperture could open and import the image without  problems; the raw fine tuning controls work, and also the adjustments. Beautiful picture, btw.



    Where are your images located? Is your Aperture library managed or referenced? Does it happen with older imports as well as with new imports?

    for some of my managed Nikon D700 NEFs

    Is there anything special about that files? Do they have a common property? Import session, size, filename (characters in the file name)?For example, national characters, like "Umlaute" can render files unreadable, if you store them on a file system that is not Mac OS X Extended.


    Have you tried the usual trouble shooting drill to get a clue, what might be going on? Importing from a different card or card reader? Importing into a new library? Working from a different user account? Can you import images from other cameras (for example your your phone)?




    MacBook Pro, OS X Mountain Lion, 2.4 GHz I.Core i7, 16GB RAM, 500GB
  • Jerry Dalton1 Level 1 Level 1 (10 points)

    I'm assuming these images are referenced images.  Is it possible you used Capture NX to edit the files, metadata, rating or anything where you might have done a SAVE from Capture NX, after the Import to Aperture?If so you might want to try copying one of the problem files to NEWNAME and re-importing it with Aperture. One more thing, have you tried to delete one of the problem files from Aperture (don't delete the master) and then re-importing it? (Make sure you have a safe duplicate stored somewhere else, peferably on a separte hard drive or flash drive).

  • Jerry Dalton1 Level 1 Level 1 (10 points)

    I just noticed somethign else. My Digital Camera Raw is version 4.03, yours says 4.01. I don't know what that means exactly but that is one difference between our systems. 


    Screen Shot 2012-11-23 at 12.52.35 PM.png

  • léonie Level 8 Level 8 (46,390 points)


    the latest official raw support release is Digital Camera RAW 4.01,

    and that is what I have too:


    Are you using a developer preview, if you are having a newer raw support?

  • Jerry Dalton1 Level 1 Level 1 (10 points)

    I'm sorry that was a mistake, my RAW is 4.01 as well.


    There is a possibility that some program data on your system has gotten corrupted. That can happen. It's a huge labotomy and not to be done unless all else fails, but it is possible to re-load Aperture.  It doesn't erase the file structure or any data. I had to do this once a few years ago.  Make sure it's all backed first, if you decide to try this.


    Before you try that...

    If you haven't done repair permissions or verify/repair disk, it's worth a try.  Sometimes data get's scrambeled and it's repairable by Disk Utility.  As usual make sure you have a backup first. Those utilities shouldn't cause an problem (I have used them for many years and never had a problem) but it's good practice to Always have a backup. Or Backups.

  • Jerry Dalton1 Level 1 Level 1 (10 points)

    I'm not a developer but know my way around computers and I have been using Apple computers and Aperture for years.

  • Jerry Dalton1 Level 1 Level 1 (10 points)

    Missing the RAW support? That is a difference worth looking into. Perhaps try re-loading the latest Aperture Upate.  There was one that came out not long ago.

  • léonie Level 8 Level 8 (46,390 points)

    That is funny -

    your signature claims you are having the current raw support installed:

    iMac 24", 2.4 GHz Intel Core 2 Duo, 4 GB

    OS X 10.8.2 (12C60)

    Aperture 3.4.3

    Raw 4.01

    Are these data not correct?



    The latest raw support can be downloaded from here:


    Digital Camera RAW Compatibility Update 4.01


    But your camera raw is not part if this update - I checked; It has been supported for a long time now, and should be supported by Mt. Lion.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.