Skip navigation

iOS 6 killed Wi-Fi Sync

83864 Views 149 Replies Latest reply: Oct 24, 2013 1:03 PM by MacUserAE RSS Branched to a new discussion.
  • simonfromquebec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2012 6:21 AM (in response to Orest75)

    try the workaround above: i've been working on it for a while, and it's working, of course i didn't update to 6.0.1: as long as people complain i won't: my solution works fine here, and syncing is rock solid since then.

     

    if you want more precisions, just ask, i'll help.

     

    And in my situation, my itunes turns on a pc that is in a wardrobe: i don't wanna go there to sync, this is why i've found the static address solution.....

     

    The situation is good for both, pc and mac.

  • vegasboyyoshi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 4:22 AM (in response to nadamala)

    Thank you so much I can sync now and I have Windows  7, but iOS 6 kill the sync ..........

  • jgleim Calculating status...
    Currently Being Moderated
    Nov 18, 2012 10:07 AM (in response to iPaulMorrison)

    Apparently, the cause of the wifi sync bug has existed since IOS 4.1 (Sept 2010)...before Apple introduced wifi syncing.  I came across an explanation of why the problem of wifi syncing occurs on the Princeton University web site... http://www.net.princeton.edu/apple-ios/ios41-allows-lease-to-expire-keeps-using- IP-address.html

     

    Here are some work-around suggestions from the Princeton web site until the IOS bug is fixed (if ever)....

    http://www.net.princeton.edu/apple-ios/ios41-allows-lease-to-expire-keeps-using- IP-address-workaround.html

  • dvdchance Calculating status...
    Currently Being Moderated
    Nov 20, 2012 8:15 AM (in response to jgleim)

    I don't think this is the cause in a majority of iTunes WiFi sync issues. THe Princeton identified bug really only occurs when the DHCP lease time is less then 1 hour in IOS 6.

     

    I'm having the issue on my home network and it has a lease time set at 24 hours so I should never encounter this bug.

  • simonfromquebec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2012 10:11 AM (in response to dvdchance)

    ...this is why with a static ip address you won't get a lease time issue: there's no lease time for a static assigned address.

    Not really elegant, but working rock solid for me(2 ipod, 1 ipad, 1 iphone). You should also associate de ip static address on the router also.

  • eriksson.e Calculating status...
    Currently Being Moderated
    Nov 21, 2012 3:27 AM (in response to iPaulMorrison)

    Hi

     

    I've had pretty much the same problem as anyone else in this thread. I'm using latest version of iTunes, OSX and iOS on my iMac late 2007, iPad 2 and iPhone 4 GSM using Airport Extreme as my router.

     

    For me, disabling sleep (power settings) on my iMac has solved the issue. So it seems as if waking from sleep somehow prevents the sync to start or sometimes finish. My iMac connects to the router via Wifi but I haven't tried if ethernet cable yeilds the same result.

     

    How do I ping Apple to get this info?

     

    /Erik

  • technolawyer Calculating status...
    Currently Being Moderated
    Nov 21, 2012 2:34 PM (in response to aubster39)

    Turning off WiFi on my Mac mini and then turning off my FIOS router and my Airport Extreme and then turning everything on again and rebooting the Mac mini worked for me. We'll see how long it lasts. I can confirm that this is an iOS 6 problem. I have an iPhone 4S and iPod touch both running iOS 5.x. Neither have this problem. Only my two new Verizon iPad minis have this problem.

  • dvdchance Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 2:44 PM (in response to simonfromquebec)

    While it still isn't perfect, having my iPhone using a static IP has help a lot. It has succesfully synched 5 out of the 7 times I've used it since I changed to a static IP.

  • technolawyer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 3:42 PM (in response to technolawyer)

    Alas, my solution worked only temporarily. After a year of WiFi syncing, it's like going back to the Stone Ages to sync via cable to my Mac. I hope Apple is aware of the problem. Also, where's that new version of iTunes?

  • simonfromquebec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 4:37 PM (in response to technolawyer)

    my solution is working well : stop using dhcp, use static adresses until apple solve the case.

    Sometimes you'll have to reboot on or two times....

     

    I really hate to plug my iphones+ipads+ipods in my closet....i really needed it to work.....and it works perfectly....Some people can achieve good results when renewing the bail, but often....it doesn't work properly.

     

    The cause is simple: there's something wrong with ios6 capabilities to maintain a "keep-alive" state between the server (itunes) and the client (ios device)....

     

    You need to be able to assign static addresses to your devices and then assign it within your router: that will keep alive the connection without bail (the bail is there to timeout an automatically assigned ip address by dhcp)....even tough you turn off your devices...or server.....

     

    When that doesn't work you just need to reboot the server and the ios devices....and let de connections reestablish themselves...

     

    Tha solution is only appliable to home network with limited clients .....but i fint it a nice workaround....it's been more than one month that i operate this manner.....it's ok for me.....it should be for many of you.

  • Ziatron Level 4 Level 4 (3,255 points)
    Currently Being Moderated
    Nov 23, 2012 7:00 PM (in response to iPaulMorrison)

    iOS 6 killed Wi-Fi Sync

     

    Just go back to iOS 5.1

  • simonfromquebec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 7:46 PM (in response to Ziatron)

    ...welllllllll...

    give me a procedure to go back there and i'm your MAN....!!!!

     

    I mean: how is it possible to revert to 5.1 without jailbreak and all specific files (i don't remember their name)....?

     

    Apple doesn't want you to roolback to 5.1......

     

    I'm opened to a simple modus operandi.

     

    ios6 doesn't worth the upgrade in my book.

  • technolawyer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 7:52 PM (in response to Ziatron)

    This advice is silly. If you have an iPad fourth generation, iPad mini, iPhone 5, iPod touch fifth generation you cannot run iOS 5.x. And even if you have a device that supports it, downgrading is not easy for the average person plus you lose out on a better operating system. The Do Not Disturb feature is amazing for example.

  • simonfromquebec Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2012 7:23 AM (in response to technolawyer)

    i don't think the advice is completely silly, even though i find it more sarcastic than simply an advice: who's able truly to rollback without violating the agreement you pass with apple ?

     

    But don't forget that the thread is a bit about the fact that apple has broken a function that a lot of people use: syncing without a fudging cable....

     

    This is why i promote: assign static ip addresses to both your router and ios6 devices (you can keep your dhcp for your other gear(s)) as a temporary workaround and that should be ok for instance...'til apple find their "black wi-fi" problem....

     

    I don't think that my solution is the best but as a professional programmer i got the habit to find a way to solve problems even when sometimes there's no obvious/elegant solution.

     

    And finally, static ip doesn't exist for fun.....it still has an usage for it, and this is a good place for using it !!!

     

    The only matter is: you have to be a bit "computaware" to make it on your router...but today's router are made for people....not for geeks anymore......

  • Coruway Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 5:37 AM (in response to iPaulMorrison)

    I follwed nadamala's instructions to sync with cable (am on Mac10.8.2 ios 6) , uncheck sync with wifi, close itunes, recehck sync w. wifi, close itunes, disconnect cable, restart itunes.

     

    This worked for iphone 4 but not ipad2.

     

    Then jumped on my right foot 3 times AND toggled DO NOT DISTURB on and off in ipad settings. Now my ipad is again syncing over wifi as is iphone. Don't forget to jump on your right foot 3 times. For people with disabilities Apple does provide a workaround. It'll be with the new release of ios which hopefully will not require people like me with ACD (Average Cognitive Disabilties) to need to jump on their left foot.

     

    But almost seriously those still trying to sync over wifi might try simply toggling don not disturb on and off. This might restart the connection. ??

1 2 3 4 5 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.