Skip navigation

USB does not recognize device - late 2010 MBP

105 Views 2 Replies Latest reply: Nov 23, 2012 4:39 PM by TiGPS RSS
TiGPS Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 23, 2012 4:01 PM

It seems the USB port is toasted but only its data circuitry. I have several USB devices that work on the first port (the one next to the thunderbolt) but only power using the second USB port. I opened up the bottom of the laptop and what I saw was some sort of overheated area right where the USB port in question is. That means something must have fried it, but what? All that's been connected to this laptop were usb drives, mice, and iDevices.

 

I tried SMC/PRAM reset, no change.

 

Does anyone know of a way to fix this without sending it to Apple?

 

Thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.