Skip navigation

Unable to search network drives with Lion...

189287 Views 492 Replies Latest reply: Apr 7, 2014 3:20 AM by DrNicolaus RSS
  • stimille Calculating status...
    Currently Being Moderated
    Nov 9, 2012 7:36 AM (in response to stimille)

    Following some advices I found on this post, I previously added some volumes in the spotlight privacy tab...so this is why terminal gave me the "Indexing and searching disabled." result.

    Now I've removed those volumes from the privacy tab and repeated the "mdutil /Volumes/_yourshare_ -i on" command and now the result is "Indexing enabled".

    In fact now the indexing seems to be working as i'm now able to search files....even if it is not flawless as before...

    hc-amis thank you very very much!


  • WhiteMAX Calculating status...
    Currently Being Moderated
    Nov 24, 2012 5:08 AM (in response to stimille)

    This AD is still a solution. I have a large 4TB server. A lot of people working on it. I need to search on the fly. Leopard always search good. Lion unfortunately not. APPLE please. Why do you make NEW OS AND WASTE GOOD OLD TOOLS!

  • SGrootendorst Calculating status...
    Currently Being Moderated
    Nov 26, 2012 2:49 AM (in response to Vance Jackson)

    The problem we had with Spotlight on a MacOSX Server was de Font.mdimporter.

    It crashes on corrupt fonts.

    So we trashed the Font.mdimporter and never had any problems again with Spotlight.

  • Saul Herrera Calculating status...
    Currently Being Moderated
    Nov 29, 2012 9:48 AM (in response to Vance Jackson)

    Just wanted to post MY results from a couple of the solutions offered inluding EasyFind.

     

    1 - I tried the the re-indexing terminal command and it DID start indexing after about 30-60 secs

     

    2 - I downloaded EasyFind to compare

     

    So, I had a shared folder named "chap" inside one of the main folders on the share

     

    BOTH were able to find files, no problem.

     

    However, neither was able to find the "chap" folder. Htye could only find it when I actually opened the main folder and then ran the search from the main folder.

     

    EasyFind had the same issue as Spotlight in this case, I'm not sure why they don't search for sub-folders.

     

    Anyway, still hoping for a solution.

     

    running 10.7.5

    searching a NAS drive share

     

    will try to post back after searching from our other Mac running 10.6.8

  • djones9000 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 16, 2012 3:24 PM (in response to Vance Jackson)

    I had the exact same problem. Using finder/folder search on a mounted drive was not doing anything. Immediately went to "0 items". Based on some suggestions here, I tried using the following terminal command and was getting same error as others:

     

    sudo mdutil /Volumes/MY_VOLUME -i on
    Error: unable to perform operation.  (-400)
    Error: unknown indexing state.

     

    I then tried adding my drive to Spotlight > Privacy list, as suggested here, but was alerted with an error saying I couldn't add the drive. This made me suspect that something was corrupt. Maybe spotlight prefs. So I deleted the prefs. This had no effect. Then I googled reseting Spotlight and came accross a solution to reset your Spotlight cache. I opened up terminal and typed: (This will cause your Spotlight to re-index everything! So it might take a while.)

     

    sudo mdutil -E /

     

    This solution worked and I'm now able to search all my network drives. Hope this helps others

  • KristopherW Calculating status...
    Currently Being Moderated
    Jan 9, 2013 11:41 PM (in response to Vance Jackson)

    Running 10.8.2 here and still having the same propblem as OP with SMB share. Given it seems to work once and a while, but rarely. Has there been an official fix from Apple?

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Jan 10, 2013 1:16 AM (in response to KristopherW)

    HI Christopher

     

    It's not broken.

     

    Please read the very last message in this thread prior to yours. You may be facing an issue but not related to anything broken with search.

  • KristopherW Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 10:41 AM (in response to LostAccount)

    Thanks, this was such are large thread and I started from the OP and started skimming until the end.

     

    djones9000 thanks for posting a "fix", my spotlight is working on my smb shared drives now. Hope It remains working so as to not have to "sudo mdutil -E /" often.

  • The WW1 Ace Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 11:11 AM (in response to LostAccount)

    Unfortunately that didn't work for me. After multiple hours of spotlight rebuilding, I still can't find anything on my SMB mount through Spotlight. The SMB file system is running on Windows 7.

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Jan 10, 2013 12:05 PM (in response to The WW1 Ace)

    It is a long thread - indeed. I should create a new one with just the answer and provide the link here or something.

     

    Glad it worked.

     

    You should find yourself rarely issuing that command.

     

    Keep these in mind.

     

    1 - Make sure indexing is 'on' for the SMB volume:    sudo mdutil -i on path-to-smb-volume

    2 - Since the index is stored locally on the client's volume, the SMB server MUST remount with exactly the same name each time or it can't pair up the server with the local index. In other words, if the server name changes or if it is a local SMB drive whose name you change the index won't pair up.

     

    Hope this helps.

     

     

    OK I created a new thread with just the answer … https://discussions.apple.com/thread/4693684

  • Rick Fernandez1 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jan 10, 2013 12:36 PM (in response to djones9000)

    It is partially working for me, where before searches yielded nothing. I now can find FOLDER names on the SMB drive. However, it will not find anything by FILE names. This seems a bizarre result and I'd appreciate any useful thoughts on this.

    Thanks.

    Rick

  • fadrianoc Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jan 25, 2013 10:44 AM (in response to Vance Jackson)

    I can see the mounted shared volume but when execute in terminal from client that command

    sudo mdutil -i on /Volumes/Name_of_shared_volume


    I receive that error:

    Error: unable to perform operation. (-403)

    Server search enabled.


    Why ? How to solve ?

  • ron App Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 5, 2013 10:30 PM (in response to LostAccount)

    It's not broken.

    It *is* broken, like many other things.

     

    I do not need to index all the network drives, but I need to search them. Like it was working in Snow Leopard - without indexing. And now it is broken.

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Feb 6, 2013 2:20 AM (in response to ron App)

    I can't believe how long this thread has become.

     

    I recommend people who are having trouble, just use the free app, easyfind. When I had issues with search, which I don't use much of I used it daily and it works!

     

    Maybe the whole thing is broken, I can share an urelated issue. Mail search is completely messed up. I have to use spotlight from the upper right corner to get results - very frustrating. I won't get into it here.

  • Profbib Calculating status...
    Currently Being Moderated
    Feb 22, 2013 12:48 PM (in response to Vance Jackson)

    I have my networked drives indexed in Spotlight, and searches seem to be functioning as expected, but I am disappointed with one detail.

     

    I have a huge collection of tagged images on the network drive, and Spotlight doesn't seem to "see" those tags, even though it can locate the image files if I type a filename (full or partial).  The same files, when copied to my hard drive, are locatable using the image tags embedded in the files.

     

    Any suggestions?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (25)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.