2 Replies Latest reply: Nov 24, 2012 10:38 AM by chrisfromgastonia
mkdavis4 Level 1 Level 1 (0 points)

i have a new iphone 5: to activate it, i am getting the message that i need itunes software 10.7.   I go to itunes UPDATES, and get the reply: your itnunes 10.63 is uptodate...


iPhone, Mac OS X (10.7.4)