1 Reply Latest reply: Nov 24, 2012 3:49 PM by Allan Eckert
Kel31 Level 1 Level 1 (0 points)

I need to update my computer to OS X 10.6.8 or later to update my Itunes in order to sync my new ipod but My computer tells me there are no software updates and I can find it on Apple. I have a black MacBook from 2008.


MacBook, Mac OS X (10.5.8)