10 Replies Latest reply: Apr 2, 2014 8:41 AM by jon filiporean
nickcc20 Level 1 Level 1 (0 points)

Hi there,

 

Im having issues with a new thunderbolt display. When my macbook is connected to the thunderbolt display im getting download speeds of 6.83. But when using the macbook on its own, not connected to the display, in the same room im getting download speeds of 19.24 according to speedtest.net

 

I have the virgin media super hub which is located downstairs. The macbook and display are upstairs.

 

I can't understand why theres such a difference in speeds just because im connected to the display. Can anyone help??

 

Nick.


Thunderbolt display, OS X Mountain Lion (10.8.2)
  • 1. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    i814u2 Level 1 Level 1 (0 points)

    I'm having the same issue. I can unplug the thunderbolt cable from the laptop and get speeds at least 10x faster (without moving the laptop at all). But when it's plugged into the display, it's slow (at times it is semi-usable but it drops in and out, which isn't usable).

     

    I have tried disabling the display ethernet, setting the display ethernet below wi-fi in service order, and switching wireless networks (I have 2.4 and 5GHz setup, on separate devices). I have another laptop that performs just fine as well (each laptop uses a separate wifi network).

     

    I saw something state that 10.8.1 beta testers were asked to test audio and wifi while connected to a thunderbolt display. Too bad I'm also on 10.8.2 and it appears broken still (again?).

     

    I'd love to hear solutions because I can't currently run a cable to the display (in the future I will but that's the next project).

  • 2. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    i814u2 Level 1 Level 1 (0 points)

    and I just figured out something semi-useful: this only happens when in clamshell mode.

    If I open the lid, it works just fine. If I close the lid, the display works just fine, but the wifi does not.

  • 3. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    nickcc20 Level 1 Level 1 (0 points)

    Yes, i agree that with the lid open it works fine. When im using the display my macbook is docked at the side of the display, so it needs to be closed.

     

    What ive had to do is get a netgear wifi range extender and put this half way between the router downstairs and the thunderbolt display upstairs, now im getting faster speeds all round, including clamshell mode. Seems the best option for me.

  • 4. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    TheBruceleeroy Level 1 Level 1 (0 points)

    Hey guys I am having this same problem but it persists with the clamshell open or not. Also instead of just getting a reduced speed I go from a 45mb connection to a .08 or basically no connection at all. It driving me crazy since I need the computer to be connected to a Wacom display for work. Any luck?

  • 5. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    Pashaweb Level 1 Level 1 (50 points)

    Hi guys,

     

    Got a new Macbook Pro 15 days ago.

    Since then I had wi fi speeds very slow.

    Ethernet works fine.

    I have tried all that is there and other discussion with no success, with the exception that after zapping the

    library/preferences/SystemConfiguration and recreating the connection, speed came up but still slow compared with the speed I should get from my provider.

    I have an old 2008 iMac that works fine with Mountain Lion and an Apple TV that runs ok with my WI FI setup.

    I have a 4MBit ADSL connection and when downloading Ubuntu ISO image from their site I have 450 KB/sec speed with iMac and my company laptop (Windows 7 & Ubuntu) while I can get only 225 KB/sec with the Macbook Pro.  Is this sign of a faulty hardware? Or it's the combination of ML & MacBook Pro Broadcom WiFi Chipset that triggers the issue? Should I bring this to Apple for repair?

  • 6. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    Sannaswo Level 1 Level 1 (0 points)

    I have managed to work around this problem by changing my main display on my MacBook Pro to the thunderbolt display. Now I finally have full internet acsess but I have to keep my Macbook open. The minute you put into clamshellmode the wifi goes back to superslow.... Still not the ultimate solution. Apple must have done something with this problem ?

  • 7. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    benduncalf33 Level 1 Level 1 (0 points)

    Same here... on a new MacBook Pro... have had many IT visits and we've just problemshooted... its the TBD! Come on Apple ***???!!!

  • 8. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    Sebastian Streckbein Level 1 Level 1 (75 points)

    I´m having the same problem: Lid closed: Wi-Fi speed slows down to snail level, lid open Wi-Fe works just fine (well, sometimes I need to reestablish wi-Fe conection or start the browser and other apps again, after opening the lid). I´m using a new MBP retina and Mac OS 10.9.

  • 9. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    nickcc20 Level 1 Level 1 (0 points)

    I have resolved my issue now, as my stock router was downstairs it would not reach the TBD, but would work with my MBP, so I got a WiFi range extender and plugged that in the same room as the TBD. So £49 later that sorted the problem for me, until the signal kept dropping. Now I have bought a netgear router, £100, and this works better, the router is downstairs. It seems getting a basic WiFi signal through the TBD is trying.

     

    I wonder if Apple will reimburse me for the extra money i have spent trying to get a PREMIUM range product to work as it should...

  • 10. Re: Slow Wi-Fi on Macbook Pro running through Thunderbolt display
    jon filiporean Level 1 Level 1 (0 points)

    try this.

     

    open System Preferences then choose Network. click on 'Thunderbolt Bridge' on the left side of the window. then click the drop down list for 'Configure IPv4', choose 'Off' then click 'Apply'.

     

    let me know if it works. all the best!