6 Replies Latest reply: Nov 24, 2012 11:23 PM by manishie
musicelect Level 1 Level 1 (0 points)
Last night I began experiencing some strange behavior with single ' and double " quotes. When I type a single or double quote an underline appears under it and seems to be waiting for additional input. Inside Dreamweaver, if I type text after the quote it becomes a closing single or double quote. Outside Dreamweaver no other quotes appear, but I get a beep from the system like I tried to do something illegal when I press an arrow key. I have to press the space bar twice to actually enter a space following a quote. Other text is entered immediately. The screenshots below show the strangely underlined quotes.










In a finder window the quotes receive an orange background:



Furthermore, if I type a single quote followed by the letter (a, c, e, o, i, u, A, C, E, I, O, U) I get a special character like:



These special characters can be created normally in OS X by typing option or option+shift and the letter. I'm not sure why the single quote is acting like an option key.

At first I thought it was just Dreamweaver doing something annoying, but I've found it is happening in just about any application that I can type in. I can't think of any recent changes to my system - no app installs or updates. I checked the Universal Access and Keyboard Preference Panes and saw nothing that would cause this wierdness. I'm trying to kill apps to see if one is causing this issue. This is very frustrating and I don't even know how it started. Any ideas?

Mark

2.2Ghz MacBook Pro, Mac OS X (10.6.6)
  • 1. Re: Strange behavior when typing quotes ' "
    TeenTitan Level 4 Level 4 (2,410 points)
    Hi Musicelect,

    Have you checked "Language and Text" in system preferences?
    If so, under the language tab, is english at the top of the list?
    Under the "Input Source" Tab is US checked? If it is checked, is Show input menu in menu bar checked? if so, on the white menu bar at the top of the screen is the little flag, is the flag US? if it's not the US flag, dose choosing the US option in the menu resolve your issue?

    if all of the above is set, and your still having the issue. under the "text" tab of "Language and Text" is spelling set to "automatic by Language" and or U.S. English? Is word break set to "standard?" and is both smart quotes set to the first time of their quote lists?

    after changing these settings you may need to quite, and reopen the application to see the changes made. As such you may want to use text edit or some other small text writing application to test with.

    good luck,
    -TT

    Message was edited by: TeenTitan
  • 2. Re: Strange behavior when typing quotes ' "
    musicelect Level 1 Level 1 (0 points)
    Yes, in the "Language & Text" pane English is on top.

    Under the "Input Sources" tab there are three selected input methods: U.S., U.S. Extended, and U.S. International - PC. Should I change these selections or choose just one?

    The input menu option was not being shown in the menu bar. I get the US flag with PC in the corner when I turn it on.

    Under the "Text" tab: Spelling: Automatic by language, Word Break: Standard, both smart quotes drop down lists set to their first selection.



    I appreciate your help. I have previously played with these options, but it didn't seem to help. The effect of this problem is global. It affects text entry everywhere I have tried typing. Finder, Spotlight, apps, etc.

    Mark
  • 3. Re: Strange behavior when typing quotes ' "
    TeenTitan Level 4 Level 4 (2,410 points)
    Try setting the language to "U.S." instead of "U.S. - PC" in the language menu of the menu bar.
  • 4. Re: Strange behavior when typing quotes ' "
    musicelect Level 1 Level 1 (0 points)
    I just did, and it solved my problem. Ugh, what kind of setting is that? I don't even know how it changed. Is there some 5-fingered keyboard shortcut or something?

    Thanks a million. You just saved me from having to do an arduous erase and install.

    Mark
  • 5. Re: Strange behavior when typing quotes ' "
    Tom Gewecke Level 9 Level 9 (71,735 points)
    Ugh, what kind of setting is that?


    The US International PC keyboard layout is very commonly used on Windows machines to type languages with accented characters. It was added to OS X because so many people switching from Windows to Mac wanted to be able to keep using it.

    If you have multiple keyboards active, it can be easy to switch among them by error via the keyboard shortcut Apple + space.
  • 6. Re: Strange behavior when typing quotes ' "
    manishie Level 1 Level 1 (0 points)

    wow, i've had my mac for about 6 months since i switched from windows, and i've had this same problem.  it's been driving me crazy and i've wasted hours trying to fix it, and this solution worked!  i also have no idea how it got switched.  thanks for the tip!