Skip navigation

Cannot use program, not supported by architecture?  I have a MacBook running 10.5 and have a Snow Leopard upgrade disk to 10.6.3, and that is the error message that I keep getting as to why my update won't install.

586 Views 4 Replies Latest reply: Nov 25, 2012 2:36 AM by roam RSS
SteelyPhish Calculating status...
Currently Being Moderated
Oct 9, 2012 5:18 AM

I have a MacBook that I am trying to upgrade to Snow Leopard so that I may upgrade it then to Lion to make better use of my iPad and some of the n we tools that Apple has made available in Lion.  I have checked and double checked that my MacBook meets the hardware expectations, and it does exceed the ones for Snow Leopard.  however, every time that I try to run the install disk it tells me that the program is not supported by the current architecture.  I have even tried to backend the processes by opening the install folder with "View Package Contents" option, but it still gives the same error message!  Someone please help! 

MacBook, Mac OS X (10.5.8)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.