Skip navigation

Display sleep problem with external monitor

5119 Views 21 Replies Latest reply: Mar 7, 2014 12:27 PM by seadoodude RSS
1 2 Previous Next
dpdpdp Calculating status...
Currently Being Moderated
Jul 28, 2012 8:01 PM

I have a 2010 MacBook Pro connected to an external 30" Dell monitor.  Since installing Mountain Lion, whenever Display sleep occurs, it turns off both monitors as it should.  But then when I wake the monitors up, two bad things happen:

 

1.  The MacBook monitor wakes up in what looks like 800x600 resolution (instead of 1440x900)  -- so everything is huge, and there are black bars on both sides of the screen.

 

2. The external monitor doesn't wake up at all.

 

Unplugging the external monitor from the laptop and plugging it back in restores the original settings and wakes the external monitor up.

 

Any suggestions (besides filing a bug report)?

MacBook Pro, Mac OS X (10.6.8)
  • 4Runner_mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 6:08 AM (in response to dpdpdp)

    I have a very similar problem, dell ultrasharp 30" connected via the mini display port.  Sleep works fine, waking up only my MacBook (2010 15" i5) wakes up, the dell monitor does not wake up.  I have to disconnect the monitor and then plug it back in via the mini display port.

  • pberk Level 2 Level 2 (240 points)
    Currently Being Moderated
    Oct 1, 2012 9:14 AM (in response to dpdpdp)

    I am working on an iMac - since upgrading to 10.8.2 my display sleeps every few minutes while I'm working.... Every few times I can't get it to wake up....I have to reboot (at least 30 reboots since this morning)

  • pberk Level 2 Level 2 (240 points)
    Currently Being Moderated
    Oct 2, 2012 6:57 AM (in response to pberk)

    After a full day of reinstalling Mountain Lion in recovery mode with the problem immediatly recurring, I noticed that my iMac was extraodinarily hot when I touched the area where you can feel the slight vibrations from the disk drive running -[ I was checking it to  see whether the display was merely blacking out and wouldn't wake, or if the hard drive was actually lshutting down....]

     

    Because of the extraordinary heat, I powered down the iMac for a few hours,  until it was totally cool to the touch.  When I turned it back on,  the problem had disappeared.....  I've been running the computer for a few hours now with no recurrance.

     

    I believe the shut-downs/unwarranted "sleeps" were in response to overheating  (Apple tech support told me that if it was overheating that I should get some beeps when it shut down spontaneously,  but I did not get any indication of this fromthe computer -- perhaps because I have an older model iMac?

     

    In any case, problem has now been resolved....

  • darks0ld13r Calculating status...
    Currently Being Moderated
    Oct 12, 2012 5:28 PM (in response to dpdpdp)

    Just recently upgraded my iMac mid 2010 to Mountain Lion. I did a clean install on a brand new Sandisk Extreme SSD. The only issue I have is my secondary monitor via display port does not wake from sleep. The only way to correct this issue is to avoid having the system sleep or reboot when I need the external monitor. The external/secondary monitor bug has been an issue since Lion (wakeup with no background) but now my secondary monitor is useless unless I reboot.

     

    This has been an ongoing issue with Apple and it looks like no one is working on a fix.

     

    So dissapointed.....

  • scfc1905 Calculating status...
    Currently Being Moderated
    Nov 8, 2012 8:11 AM (in response to dpdpdp)

    I and a friend have similair issue.

    Macbook Pro late 2009 and 2011. Issue has started since upgrading to Mountain Lion.

     

    When connected to external monitor (in my case a Apple 23") and macbook is left on after a few hours it goes to sleep, till now all fine.

    However when I try to restart:

     

    1. Macbook does not react to mouse or Keyboard

    2. light is out (not flashing)

    3. machine is on, you can here it when you get real close

    4. Macbook is very hot

     

    Nothing helps but hard restart!

     

    It seems an issue with Mountain Lion and energy saving. I have reset the PMU etc..

  • BrendonWBrown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 5:00 AM (in response to dpdpdp)

    Similar issue here, but in my case neither display comes on at all. This occurs for me not when the mac had gone to sleep, actually, but when the display turned off due to energy saving setting or a hot corner.

  • JosephBergdoll Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2012 11:19 PM (in response to dpdpdp)

    When connected to an external display and going into sleep (either via energy saver or alt+cmd+eject), it cannot be woken up on EITHER display… I have to force a hard reset, always. I have reset the SMC and NVRAM numerous times, turned off "wake for network access" etc… no dice. Very frustrating considering I rarely use my computer away from a desk. This occurs on a 15.4" Late 2008 Unibody MBP with both a 23" aluminum Cinema Display, as well as a 24" Dell UltraSharp 2408WFP. Extremely annoying.

  • BrendonWBrown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2012 8:51 AM (in response to JosephBergdoll)

    Update to the issue: the only (unfortunate) solution I've encountered was a full clean install of Mountain Lion. What a pain! This also solved the huge slowdowns I was encountering and the icon drag problem. It would be interesting to know how many of those with these problems merely upgraded to ML without a clean install.

  • 4Runner_mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 12:41 AM (in response to BrendonWBrown)

    I upgraded to mountain lion.

  • 4Runner_mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2013 10:39 AM (in response to dpdpdp)

    I've since upgraded to a new Macbook Pro Retina and did a fresh install of Moutain Lion as well and I'm still having the wake issues about 50% of the time.  Disconnecting the display adapter and plugging it back in is a workaround for me.

  • amuteau Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 6:31 AM (in response to dpdpdp)

    I have a similar problem, when i put my mac pro in sleep i cańt detect the display, i have to unplug and replug the displayport,

    Dd you find a solution ?

  • BrendonWBrown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 10:05 AM (in response to amuteau)

    Yes and no. My fresh install of Mountain Lion mostly solved it. I still need to hard reset, but much less often.

  • Eric Root Level 6 Level 6 (13,875 points)
    Currently Being Moderated
    Apr 6, 2013 10:45 AM (in response to dpdpdp)

    If you disconnect the external monitor, does the MacBook Pro act normally when it wakes from sleep?

     

    Hook up the external monitor and try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart. For each disable/delete, you will need to restart if you don't do them all at once.

                   

    Safe Mode

     

    Safe Mode - About

     

    Apple support article:

     

    Video Troubleshooting Internal and External Monitors

  • amuteau Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2013 10:55 AM (in response to Eric Root)

    I already did it, and aslo reset the pram.

    Even in safe mode, when i put my mac pro in sleep, the monitor don't work when awake.

    One more information, i have an adaptor displayport / vga generic ( not from apple) do you think that this is the problem ?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.