Skip navigation

why isnt my battery "not charging:

536 Views 7 Replies Latest reply: Nov 27, 2012 8:50 AM by Tu Chico Latino RSS
MegaRome Calculating status...
Currently Being Moderated
Nov 25, 2012 7:59 PM

My macbook has stopped charging. It continually says "not charging" even when plugged in with the mag. I've tried several steps such as, turn off macbook, take out battery, unplug mag safe, hold power button 5 seconds, plug mag safe back in and pop battery back in. Nothing works.

 

 

Help me please

MacBook, Mac OS X (10.5.8)
  • frederic1943 Level 6 Level 6 (9,970 points)
    Currently Being Moderated
    Nov 25, 2012 8:10 PM (in response to MegaRome)

    Go to the Apple in the upper left corner and select About This Mac, then click on More Info (and then System Report, then select Power from the left hand column of the System Profiler. Copy and paste the Battery Information from the top of the page back here.

  • Tu Chico Latino Calculating status...
    Currently Being Moderated
    Nov 26, 2012 3:29 AM (in response to frederic1943)

    I have exactly the same problem.

     

    Here the info you need:

     

    Battery Power:

      System Sleep Timer (Minutes):          0

      Disk Sleep Timer (Minutes):          0

      Display Sleep Timer (Minutes):          0

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Display Sleep Uses Dim:          Yes

      Reduce Brightness:          Yes

     

     

    Extra info: Green light on the charger is off. But when I plug in the charger, the latptop knows and increase the brightness. I have two batteries and the problem is identical with both. I checked the SMC firmware and I have installed the latest.

    Please help

  • frederic1943 Level 6 Level 6 (9,970 points)
    Currently Being Moderated
    Nov 26, 2012 10:42 AM (in response to Tu Chico Latino)

    No, not the Battery Power, the Battery Information at the top.

  • Tu Chico Latino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 1:56 AM (in response to frederic1943)

    Thank you for your help. Here the info you asked for.

     

    Note: Today I un-plugged and plugged several times. I got the green light for less than a second, then quickly changed to orange for another second and then is off. There is no light on magsafe. BUT the icon on the screen says charging. Crazy... everday different behaviour...

     

     

    Battery Information:

     

      Model Information:

      Serial Number:          9G8420Q0P13DB

      Manufacturer:          DP

      Device name:          bq20z951

      Pack Lot Code:          0000

      PCB Lot Code:          0000

      Firmware Version:          002a

      Hardware Revision:          0005

      Cell Revision:          0100

      Charge Information:

      Charge remaining (mAh):          888

      Fully charged:          No

      Charging:          Yes

      Full charge capacity (mAh):          3209

      Health Information:

      Cycle count:          380

      Condition:          Normal

      Battery Installed:          Yes

      Amperage (mA):          -33

      Voltage (mV):          11621

  • White-1 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Nov 27, 2012 2:00 AM (in response to Tu Chico Latino)

    I do have the same problem. The light goes off if I move the wire, but it does charge. Are you sure that it doesn't charge?
    Plug it out again and put it back in and check that the light would be on.

     

    Sorry, I didn't read your replies.

    Yeah, it is a different problem. How old is your battery ? Even 5 years old battery should work well and hold at least 3 hours of charge. Maybe it's the issue with the magic safe?

  • manelady1 Calculating status...
    Currently Being Moderated
    Nov 27, 2012 3:54 AM (in response to White-1)

    Check the magnet/magnets, see if you could have picked up some small metal particles causing the disturbance.

  • Tu Chico Latino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 8:50 AM (in response to manelady1)

    First of all, thanks both for your comments.

     

    Indeed today is charging, but the light keeps of, not orange or green. If the light were the unique problem I woudnt mind. But yesterday for example it didnt charge at all. I dont know why today it decided to recharge the battery, that by the way, is about 3 years old.

     

    I double check the magnets, I also checked the version number of my SMC software, and everything looks fine.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.