Skip navigation

Cursor disappears in Mail 6 on Mountain Lion

15662 Views 117 Replies Latest reply: Apr 6, 2014 9:53 AM by Beacher3 RSS
  • Beacher3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 12:31 PM (in response to Stephen Schulte1)

    Yes I agree ..... I think it may have something to do between Mail and Hide Others, which ASM essentially is doing via a script I think? It is surprising to me that 10.8.1 and 10.8.2 hasn't fixed this yet?

  • justinbr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 2:46 PM (in response to Beacher3)

    This is happening to me as well.  In Safari, Mail and Photoshop CS6.  It can happen at any moment and seems largely random.  I do not use hide all or hide it which debunks that theory.  To me this happens most often in photoshop when using healing brush or tools similar that use rendering and the graphics card to illustrate target area.  The pointer simply disappears and can return on it's own after minutes if you have that kind of time that is.  I do not!  Show desktop and clicking anywhere on desktop brings the pointer back which allows me to return to work in PS.

     

    Apple need fix this soon.  It is defintely something to do with OSX 10.8 and has rendered my computer fairly useless.

     

    I would urge everone to report bug to apple to get their attention:

    http://www.apple.com/feedback/macosx.html

     

    2 x 2.8 GHz Quad-Core Intel Xeon 12 GB 800MHz DDR2 ram 10.8.2

  • corinnafromsan juan capistrano Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2012 7:27 PM (in response to justinbr)

    Thanks for the link, justinbr! I submitted my feedback.

  • jim_b_o Calculating status...

    I've had this problem for months.  It is reliably reproduced by first selecting a message in the side bar so that it is being displayed in the main area of the window and then creating a new message.  The mouse will then track erratically over the composition window and sometimes vanish altogether.  It can sometimes be fixed by clicking in a different window then coming back but it is hit and miss.

     

    I've tested clean 10.8.0/1/2 installs (no third party software etc) which all exhibit the problem as does 10.7.0.

     

    The problem does go away for me if I turn off "Automatic graphics switching" under "Energy Saver" in System Preferences.

     

    Almost identical symptoms also occur when viewing a PDF in Safari as discussed in http://openradar.appspot.com/12240182.  Again this can be prevented by turning off "Automatic graphics switching".  Interestingly the PDF issue only occurs when the mouse is over some text in the document.  It's fine over a blank section of a page.

     

    I raised the issue with Apple Support and exchanged videos, system reports etc.  There was a recent admission that we're not all dreaming so fingers crossed for a fix in the near future.

  • jim_b_o Level 1 Level 1 (0 points)

    That might suggest it's a driver problem with the built in GPU rather than a switching issue.  Is there any similarity in our GPU's?

     

    Chipset Model:Intel HD Graphics
      Type:GPU
      Bus:Built-In
      VRAM (Total):288 MB
      Vendor:Intel (0x8086)
      Device ID:0x0046
      Revision ID:0x0018
      gMux Version:1.9.22
  • jim_b_o Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 7:20 AM (in response to jim_b_o)

    P.S. My machine is similar vintage - MacBook Pro-17" (mid-2010)

  • drdocument Level 4 Level 4 (2,995 points)

    This issue has been widely reported. It still happens to me occasionally.

    I think Apple is aware of it, but giving feedback can only help.

  • Pete Eisenmann Level 4 Level 4 (3,145 points)
    Currently Being Moderated
    Nov 23, 2012 12:17 PM (in response to drdocument)

    I have been tracking this discussion for a while since I am having the same problem since upgrading to 10.8. I can duplicate the issue as explained. Very frustrating.

     

    Until Apple fixs this, I have been using a keyboard short cut to, at least, save time from having to click in another window and return. In Mail, when you see that the cursor is gone, use the key combination of "Command - ~ (tilde)". This is a quick way to switch between open windows in Mail (and other programs), and once you switch back to the email that you are working on the cursor will be back. Still a PITA but less so.

     

    Come on Apple please fix this - given feedback too.

  • Pete Eisenmann Level 4 Level 4 (3,145 points)

    Hi Steve,

     

    On my keyboard the tilde key (also the grave accent) is the top upper left key - to the left of the number 1 key. I just hold down the Apple - Command key and then hit/press the key (while holding down the command key) to cycle through any open windows in that application, or in Mail's case for my purposes, one full cycle will return the cursor to a visible state.

     

    You can find a list of common shortcuts in any number of places - here is one from macrumoors: http://guides.macrumors.com/Keyboard_shortcuts

     

    Hope this helps,

     

     

    Pete

  • BobF4321 Calculating status...

    I have been having this problem lately... seems related to Mountain Lion or one of its updates.  Can't pin it down to a particular app.  My workaround is to move my mouse (trackpad) down to expose the dock... then the cursor reappears.  But I have a dual-monitor configuration, so it's fun flying blind to get the cursor back to the screen with the dock!  Apple should have an accessibility feature to identify the cursor location with big flashing arrows.... or force it to be repainted.

  • Edgar Level 3 Level 3 (960 points)

    Finally I found this threat because i'm having this issue too and it is driving me nuts.

     

    I use the Notes app a lot since ML and there it happens all the time and lately I noticed it too with Mail. First of all, I can confirm that it is the "Hide Others" command and you can get the curser back in the application when you toggle between two windows in that app.

     

    I experienced that issue only since ML, but here is another bug I try to solve where I don't know if it is related. It is very specific but I want to point it out. Maybe someone has an idea.

     

    I'm using Logic Pro with an external controller Euphonix MC Control. I always have the issue that the touch display of the controller

    looses its functionality during the day when I work in Logic and I have to restart the controller to get it back. I couldn't find the reason for it, all the trouble shooting didn't bring up anything and the now (Avid) customer support was of no help either. About two weeks ago, I finally stumbled over the needle in the hay stack. It was the "Hide Others" command which I use a lot. I can reproduce the bug 100% of the time. Using the "Hide Others" command will disable the controller's touch screen functionality.

    Now you can imaging my surprise when I read about the "Hide Others" problem on this thread. I have to say that I had the problem with the controller and Hide Others already in Snow Leopard (maybe even Leopard), so this is not limited to ML like other people on this thread suggested.

     

    Does anybody know if there is a Terminal command to disable the Key Command for Hide Others (opt+cmd+H). I use it all the time for years and it is almost a reflex that is hard to "untrain".

     

     

    Edgar Rothermich

     

    http://DingDingMusic.com/Manuals/

    'I may receive some form of compensation, financial or otherwise, from my recommendation or link.'

  • maharaj Level 1 Level 1 (105 points)
    Currently Being Moderated
    Dec 5, 2012 11:17 AM (in response to Edgar)

    i have the same problem - cursor disappearing in Mail 6.2 ML OSX 10.8.2.

     

    Really annoying, seemingly a most basic programming mistake and can't be fixed this long? When people start talking about "Terminal" and getting stuck with "~" keystrokes blah blah - I'm probably just an impatient SOAB but phew.......

    Add to this the intermittent sound alerts in Mail, discussed forever in another thread, to say nothing of the totally disabling problems for many with Logic Pro. I hate to be a moaner but we are proud Apple users - we're not used to so many basic functions screwing up in our beloved OS !!!!

1 2 3 4 5 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.