Skip navigation

After Lion upgrade, my addressbook does not work++

21425 Views 71 Replies Latest reply: Jan 3, 2014 3:57 AM by cuckoo57 RSS
  • Confused of Sussex Calculating status...

    You are a good and patient man Barney-15E.

    I've followed all your advice but still Mail doesn't work properly. If I am in Safari and then click back into an email in Mail, nothing happens. If I then double click sometimes the email highlights and sometimes not. Even if it does, it doesn't show its contents in the preview pane. If I then click around and sometimes even right click it eventually does show its contents.

    Once it starts working it carries on working correctly until I go into Safari again and then coming back to Mail produces the same problems.

    Any suggestions?

  • Barney-15E Level 7 Level 7 (33,400 points)

    This thread doesn't really have anything to do with Mail, and your problem doesn't appear to have anything to do with Address Book.

    However, it does sound similar in that it might be the index that Mail creates. You should start a whole new thread to get your problem solved independently of this thread.

    Go back up to the Lion discussions and click on this link:

    Screen Shot 2012-07-31 at 5.30.38 AM.png

    There is a nice program that can remove the mail envelope index easily. It is called OnyX. You will find the checkbox under the Maintenace section, Rebuild tab.

    When you use OnyX, don't get excited thinking there is all of this Maintenance that needs to be done regularly. It doesn't. You use tools like OnyX when required for specific events, like yours. There is no reason to use any of the functions in OnyX on a regular basis.

  • Confused of Sussex Level 1 Level 1 (0 points)

    Thanks for all your help.

    In the end I phoned Apple Support and they suspected it was that my user account had corrupted somehow whilst upgrading to Mountain Lion. They took me through rebooting from the recovery partition and rebuilding my user account and hey presto, so far it appears to have worked.

    I thought that you might like to know this to add to your obviously extraordinary knowledge of these matters.

  • DD67 Level 1 Level 1 (0 points)

    Thanks so much Barney, this has worked!

    HOORAY!!

  • Martunes Level 1 Level 1 (0 points)

    You're the best Barney!!

  • stephaniefromarlington Calculating status...

    Wow, after an hour getting increasingly and insanely frustrated, I found your suggestion and tried it and it worked!  I cannot thank you enough, Barney.  My family thanks you, too, and now feels they can come near me again. 

  • johncr Calculating status...

    Barney, I have followed your steps set out for tempelboy, deleting the file Addressbook-v22.abcddb, then re-opening Addess book. It's empty, eg no data, although a new replacement for the deleted file was immediately created. Do I re-import the data from somewhere? Or turn iCloud synch back on?

     

     

    OS X 10.7.5  on a 2.16GHz iMac (late 2006)

  • Barney-15E Level 7 Level 7 (33,400 points)
    Currently Being Moderated
    Nov 26, 2012 5:58 PM (in response to johncr)

    Turn iCloud sync back on.

     

    The file should have been recreated using the metadata folder contents. If there is nothing in the metadata folder, that could be why.

  • johncr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 11:57 PM (in response to Barney-15E)

    Thank you Barney. Turned iCloud synch back on and the data returned. Metadata is filled with ABSmartGroup.abcdg records only.  The search function still does not work.

     

    The right-hand page is stuck on the first record in the database, whereas after scrolling to search for a record, a double-click on the name opens a separate window. Smart Groups still works, that is the relevant records appear with a click on the smart group name; but the individual records will not open as before.

  • Barney-15E Level 7 Level 7 (33,400 points)
    Currently Being Moderated
    Nov 28, 2012 4:39 AM (in response to johncr)

    Check inside the Sources folder. There are separate folders for each type of contacts servers (like iCloud). They are named with a unique id #. Each of them has its own addressbook-v22.abcddb file. The one for iCloud may be the issue. Delete it and then open Contacts and see what you get.

  • johncr Level 1 Level 1 (0 points)

    It did not work the first time Barney, and along the way I found what seemed to be a corrupted record, but after deleting that it all works again. Many thanks, John

  • sharae Calculating status...
    Currently Being Moderated
    Dec 19, 2012 10:03 PM (in response to tempelboy)

    I had the same problem earlier today (address book search not working). After trying to delete preferences, restart system, etc I called Apple (I have AppleCare). While waiting for the advisor, I searched the Apple Community Forums and found clues to the issue - a corrupt address database index (Thank you Barney!).

     

    Rather than reinstalling my operating system, which is what Apple initially suggested to cure the problem, I decided to try:

     

    1. Backup system with time machine

    2. Navigate into Application Support/AddressBook.

    3. Delete addressbook.abcddb (the address database index) by moving it to my desktop

    4. Restart system

    5. Launch address book (search works again)

     

    So far, everything works again. I'm using OS 10.7.5, and am not syncing to iCloud.

  • Stephen Mahowald Calculating status...

    I tried this. When I open my Contacts it comes us fine. On the left page it shown under "All Contacts" two subsets: the first if "All on My Mac" and that shows no contacts when highlighted. Under that is my synced Contacts which has all of my addresses. The Mail program will not let me access the particular Contacts file that has the addresses and only provides acces to the Contacts file which has not addresses in it. I can copy the cards from the full file to the empty file, but only one at a time. But even then, the Mail program does not recognize either of the Contacts files. I sure hope I haven't made this too confusing -

  • Stephen Mahowald Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 27, 2012 1:56 PM (in response to tempelboy)

    I did try this - twice - no change. The problem seems to have settled down to this:

    In Mail, when opening the Contacts, it is not connecting me with the Contacts file that was copied during the transfer of data to the new iMac. I can find no way to redirect the Mail search to the correct Contacts file. Any help would be appreciated. Thanks.

  • aoitsukinosuke Level 1 Level 1 (0 points)

    Barney - This solved my problem.

    Thank you so much.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.