Skip navigation

rm: illegal option --M (terminal problems) - Empty Trash

2720 Views 6 Replies Latest reply: Nov 26, 2012 1:27 PM by MarkWolfe RSS
SunshineSinCity Level 1 Level 1 (0 points)
Currently Being Moderated
May 29, 2011 8:45 AM

I had some locked files. Couldn't delete them. Used sudo command in terminal to no avail. Used the 'unlock' file instructions from support page. Went into single-user mode, followed instructions. Blue screened at end. Rebooted. Was able to unlock file from desktop that was previously locked. Now I try to empty trash, but locked files won't go away.


I run terminal app (sudo command to empty trash) and get this error:

rm: illegal option --M

usage: rm [-f | -i] [-dPRrvW] file ...

unlink file


Please help, not sure what to do at this stage.



iBook, Mac OS X (10.4.6)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.