Skip navigation

Why is Mail so slow on Mountain Lion?

8039 Views 16 Replies Latest reply: Nov 14, 2013 3:16 PM by mjos50 RSS
1 2 Previous Next
Neil Wainwright Calculating status...
Currently Being Moderated
Aug 9, 2012 5:15 AM

Hi there, I have about 200,000 e-mails in my mailbox. Double-clicking regularly takes 5-10 seconds to open with the "Loading..." message. Also, file attachments don't seem to be there when I open an e-mail downloaded 15 minutes or more prior. It feels a lot slower that Lion. I was hoping it would be faster. I hope they work on optimizing Mail, because it doesn't feel better than Lion.

 

Thanks...Neil

  • calebfrom84042 Level 2 Level 2 (355 points)
    Currently Being Moderated
    Aug 9, 2012 5:39 AM (in response to Neil Wainwright)

    Try repairing your permissions.  Go to applications then to the "other" folder then go to disk utility, on the left hand side you will see a white box.  Select the second option, usually called "mac HD" with that selected click on "repair permissions" in the center towards the bottom of the screen.  Wait for it to complete, then see if this fixes the issue.

  • Linc Davis Level 10 Level 10 (107,930 points)
    Currently Being Moderated
    Aug 9, 2012 6:28 AM (in response to Neil Wainwright)

    Quit Mail.

     

    Back up all data if you haven’t already done so. Before proceeding, you must be sure you can restore your system to the state it’s in now.

     

    In the Finder, select Go Go to Folder... from the menu bar, copy the text on the line below into the box that opens, and press return:

     

    ~/Library/Mail/V2/MailData/Envelope Index

     

    Delete the selected file. Relaunch Mail and test. It should re-index your mailboxes.

  • Hectic Haggis Calculating status...
    Currently Being Moderated
    Sep 10, 2012 5:47 AM (in response to Linc Davis)

    thanks - for a newbie can you advise how to back up the mail sufficiently?

    thanks

  • KTransue Calculating status...
    Currently Being Moderated
    Sep 23, 2012 6:26 AM (in response to Linc Davis)

    Linc:  That was perfect!  Thanks!  My [same] problem solved!

  • KTransue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 6:34 AM (in response to Hectic Haggis)

    If you're using Apple's "Time Machine" to do your backups, you're doing sufficient backups already.  Just remember that you're messing around under the hood, and be careful about what you do.  I just used the "duplicate" command to create a copy of the Envelope Index file until the process was done, and then followed the rest of Linc's instructions.  After I proved to myself that everything worked, I deleted the copy.

  • Stressed Mum Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 9:52 AM (in response to KTransue)

    Yay!  This worked for me too!  thank you - however, word of warning to those that rushed into like me....  COPY THE FOLDER FIRST - just in case...  Also, when you restart Mail you will get a few minutes delay whilst Mail imports all your folders again - depending on how many you have this could take a good few minutes - which can be an axious time - particularly if like me you didn't take a copy of the folder (although I do have TM).  Then once the files loaded I got a warning for each mail box to say that mail was damamged and needed to quit - I had to do this import and quit  3 times before Mail 'settled'... phew!  A bit of a worry - but my Mail is now working super fast - just the way it did before ML upgrade.  Thank you Linc!

  • JWigginsDesigns Calculating status...
    Currently Being Moderated
    Oct 10, 2012 3:28 PM (in response to Linc Davis)

    Hi! I'm prefacing this by saying it is in no way your fault; however, I'm in a bit of a pickle. I duplicated my Mail folder and moved it to my Desktop. I tried deleting the file you suggested. Twice Mail crashed on me. I finally went into my System Preferences and removed my MS Exchange account all together. After reloading it, I opened Mail and it proceeded to import. Everything with Mail is now fine (appears so). But my issue now is with Notes. It crashes every time I try to open it. I went back to System Preferences and unchecked the Notes under my MS Exchange account. Reopening Notes, it worked fine (being it was only syncing my iCloud notes at this point). Every time I try to sync my Exchange notes again, it crashes. I'd appreciate any wisdom you may have for fixing this issue. It's not a huge deal in that I don't often use my Exchange notes, but for the principle of all things working correctly, I'd like to fix it. Help!

  • drdocument Level 4 Level 4 (2,995 points)
    Currently Being Moderated
    Oct 10, 2012 3:39 PM (in response to Neil Wainwright)

    One strategy which works for me is moving older emails to a folder named "Archive" in "On My Mac".

     

    As a monthly routine, I select all emails more than 60 days old from my Inbox and move them to an "On My Mac" folder named "Received Archive," and the same with Sent messages, to a "Sent Archive." They are then removed from the server, but still available if I want to search them.

  • JWigginsDesigns Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 11:06 AM (in response to JWigginsDesigns)

    FYI, I solved my problem with Notes the same day.

     

    The solution: Deleting  ~/Library/Containers/com.apple.Notes.

     

    Here's the thread where I found the answer - https://discussions.apple.com/thread/4142571?start=45&tstart=0

  • jenn_dc Calculating status...
    Currently Being Moderated
    Nov 9, 2012 6:33 AM (in response to Linc Davis)

    I did this today and my email seems to be working normally now, however, when I searched "Envelope Index" in "mail data" afterwards - to delete the copy of the file I made before starting, I've found that I now have 10 versions of Envelope Index with various ending all created today.  I don't know if I should delete those or keep them.

  • HollywoodIndustries Calculating status...
    Currently Being Moderated
    Nov 27, 2012 9:50 AM (in response to Neil Wainwright)

    Wow this is painfully slow. Just did a clean install of Mountain Lion on a brand new SSD. Coming from Snow Leopard, everything has been great with Mountain Lion so far, EXCEPT for outgoing email. It is insansely slow!!

     

    Something is definitely wrong, it should not take 20 minutes to send a 7mb file on a T1 connection. Jeez....

     

    it sends at 3 kb/s !!!

     

    Never had any issues with snow leopard.

  • mike219 Calculating status...
    Currently Being Moderated
    Dec 15, 2012 10:43 AM (in response to Linc Davis)

    Deleting the Envelope Index file worked for me as well.

     

    ~/Library/Mail/V2/MailData/Envelope Index

     

    Thanks, it was getting really annoying waiting for emails to load and delete.

  • jpachner Calculating status...
    Currently Being Moderated
    Jan 21, 2013 1:31 PM (in response to Linc Davis)

    Just want to thank you very much Linc for this advice, which worked for me. 

    Before deleting the Envelope file, I did duplicate the original, as suggested.

    The first time indexing failed, but it worked fine when I tried it again.

    Again, many many thanks.

  • Dutch Level 1 Level 1 (60 points)
    Currently Being Moderated
    Feb 2, 2013 2:12 PM (in response to jpachner)

    The fix don't fix mine. Still slow to send e-mail, about 30 sec.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.