Skip navigation

Aperture Registration Screen ad nauseum

512 Views 9 Replies Latest reply: Nov 28, 2012 8:28 AM by léonie RSS
Texas_Man_Luvs_His_mac Calculating status...
Currently Being Moderated
Nov 27, 2012 12:35 AM

I have had an issue with my 17" macbook pro, last model made, 16 gb ram, getting slower and slower. I've kept most information on externals, lots of backups to TM (x2) and offsite with backblaze.

 

I noticed on OWC a sale on SSD. I can replace my HD with a new 490gb SSD and put a larger HD in the DVD bay. Works like a charm.

 

I have more room than ever before.

 

Oh has this ever cost me, though.

 

I can't backup to backblaze anymore (working with them on that). Seems the new SSD HD has just thrown everything off and now I need to completely start from scratch and spend weeks with my computer backing up. I have the fastest home verizon FiOs one can ask for, but I also have a lot of photos and video. Perhaps too much so.  This is going to take forever. Biggest fear of mine is electrical. I live in a location where electrical storms are intense and unpredictable, have two layers of redundancy on backup power supplies and power surge protection, for whatever that is worth.

 

Nothing like waking up in the middle of a storm that wasn't predicted and feel the lightning/thunder rocking the house. Neighbor/friend of ours had a direct hit a few months ago and her house was fried. She walked in and found her fireplace on, ice cubes all over the floor, TV's and everything electrical fried, you get the idea. I kid you not when I say we were just moved in here in 2003 (between Fort Worth and Oklahoma) and were looking at the storm out our back window. All four of us. We had never seen such violence in the air coming from South Texas all our lives. The storms in the plains of North Texas near the Oklahoma border are most impressive. We witnessed a lightening strike right in front of our eyes in our back yard. It sucked the air out of the room (seemingly) and time seemed to freeze for just a moment. The percussive shock a second later popped our ears and we all scattered like mice. It was a sight. Ears rang afterwords too.

 

Needless to say, I look at my in-house backup (12TB Pegasus and Buffalo 4TB) as only a quick fix. Theft, fire, and especially electricity can undo those in a hurry.

 

I am frustrated. I suppose I could have worse to worry over, so I need to count my blessings. There was a time in 2008 when I wanted to get out of a hospital bed while fighting aggressive B cell lymphoma for 8 months. I really have nothing of substance to complain about.

 

Yet starting this process to increase internal HD capacity and speed up the computer (was getting very slow and HD was acting odd) is really frustrating.

 

 

The primary reason for my post:

 

At the moment, having trouble with Aperture. I, for whatever reason, have found every disk I have every owned except my Aperuture disks. I pulled the app off of TM. I've been doing a full fresh reload on everything, but had to go with the copy of Aperture from TM.

 

I'm almost ready to just chuck all this effort and buy another copy of Aperture for $79 from the app store. Endless downloads sound nice about right now.

 

I can't get past the registration screen easily. I have been trying for weeks. I have all the info: original numbers, upgrade numbers. I have to enter all my info, and then I have to enter the upgrade key, then I have to enter the original key. In that order, every time. My info, then prompts for upgrade key, then original key. If I reverse the order of the keys, it says they are not valid.

 

Whiny, I know. But frustrating. I have trashed preferences to no avail. I keep looking for my disks, and daily, I keep entering the same information. Over and over each time I start up Aperture.

 

Due to the high unpredictable electrical nature of things, I keep all my electronics unplugged and away from any wires unless I am actually on them. Not sure that will help, but gives me the satisfaction of believing I am doing all I can to protect it.

 

But this approach requires me to start it up each day I use it, sometimes several times a day.

 

I will say, the upgrade is incredibly zippy. It was taking almost two minutes from pushing the power button to having Aperture open. Now it is a matter of 15 seconds or so.

 

Ideas on what to do to stop this registration issue ad nauseum?  I'm also open to ideas any of you photo/video hobbiest like me might have for further electrical safety and back up redundancy. 

 

I sure don't want to lose all this work.

 

Thanks

MacBook Pro, OS X Mountain Lion (10.8.1)
  • Aye Es Oh Calculating status...

    If I'm reading your post correctly, the problem could be that Aperture was moved instead of reinstalled, which could cause registration issues. You could try deleting, reinstalling, re-registering, then upgrading Aperture again in that case.

     

    There could also be a problem with the file that holds the serial info. This is stored in a file called ProAppsSystemID, which is stored in /Library/Application Support/ProApps. Quit Aperture, and navigate to this folder from your main hard drive, then move the ProAppsSystemID file to the trash. Restart your machine, then re-register Aperture and see if it works correctly, and let us know whether or not it does.

     

    None of this should affect your data in any way, although you should always have a backup just in case.

  • léonie Level 8 Level 8 (46,355 points)

    ice cubes all over the floor, TV's and everything electrical fried, you get the idea.

    I get the idea, what a story!

    But if you want protection for your data, unplugging alone will not help, in such a case. You will need a second backup at a different location. Perhaps store your most important image files in the cloud for an additional backup.

     

    What is your Aperture version? The most recent version 3.4.3 is supposed to fix a bug related to registration number issues.

     

    Regards

    Léonie

  • léonie Level 8 Level 8 (46,355 points)

    If you still have the Aperture 3 registration numbers, you can reinstall Aperture from the Trial version. This support article describes how to reinstall, and contains a link to the Aperture Trial:

     

    Aperture 3.4: May quit unexpectedly on launch after updating

     

    If you decide to reinstall, it is important to run Software update immediately after the Trial installation - don't try to launch Aperture first. This cannot succeed, since your Aperture Library will be of a newer version than the Trial.

  • léonie Level 8 Level 8 (46,355 points)

    apples website says it is no longer available.

    Yes, it has been discontinued, but is still available for trouble shooting. That is why I pointed to the other link on the trouble shooting page to reinstall: Aperture 3.4: May quit unexpectedly on launch after updating

    Procede like described in the last paragraph and download here: Aperture 3.1 Trial

  • léonie Level 8 Level 8 (46,355 points)

    I did move over the app from time machine. I figured that was the issue.

    One more thing, just to be clear. If you want to run Aperture by reinstalling from a Time Machine backup, you cannot make a clean install. Aperture needs many items from the system library. You would need to transfer your previous installation by having the Setup Assistant transfering the libraries and Applicaqtions as well. Transfering the Aperture application  alone is not sufficient. You will need to run the Aperture installer, to install necessary frameworks and configuration files.

  • léonie Level 8 Level 8 (46,355 points)

    You are welcome, Robert.

     

    I am glad it works for you again.

     

    And I'll have a look at your flickr account!

     

    Cheers

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.