Skip navigation

Xcode says "no editor" from launch and freezes.

5060 Views 16 Replies Latest reply: Mar 2, 2014 5:15 PM by hsrob1 RSS
1 2 Previous Next
EGibs Calculating status...
Currently Being Moderated
Mar 18, 2012 4:25 PM

When I launch Xcode from the Launchpad I get a blank white screen. Sometimes it says "no editor" in the middle of it, and other times it just has the loading circle. When I try to click anything on the top bar such as the Xcode or file tab, then I get the beachball cursor. I end up having to force quit because it stays like that. Xcode worked fine until I put some of my Xcode projects into the trash but when I "put back" the projects it does the same blank white screen. I've tried uninstalling twice but it hasn't changed anything. I'm using Lion with the newest version of Xcode.

  • xnav Level 5 Level 5 (6,615 points)
    Currently Being Moderated
    Mar 19, 2012 8:18 AM (in response to EGibs)

    I had a similar issue that was finally resolved when I used Time Machine to restore the entire project file that Xcode had open when it first failed to the state one hour before the project was opened.

  • gabord13 Calculating status...
    Currently Being Moderated
    May 18, 2012 6:51 PM (in response to EGibs)

    sorry for not posting a solution but i am just +1 this, as I have exactly the same problem.. reinstalled xcode many times now..from appstore and manually too, did the magic sudo /Developer/Library/uninstall-devtools --mode=all .. and then luck.

  • fmasini Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 21, 2012 9:43 AM (in response to EGibs)

    Sorry for my bad english ... I have the same problem. When I installed xCode, it ask me a path for my projects, i set a directory on my disk, and since the first launch, i have the same crash with a blank "No Editor" window.


    I have reinstalled it many time, and tried the sudo command. Every time the same problem.
    Can i have a clean install for xCode? How can i do?


    Can anyone help us? Please

  • gabord13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 1:33 PM (in response to gabord13)

    got it!

    To reset the XCode for the current user You will need to delete the file:


    /Users/<UserName>/Library/Autosave Information/


    at lease for me it worked. (I previously deleted every xcode related things, and installed back the XCode, but this file remained there, so the XCode always started with "no editor".)


    Now it works...:)


    Hope this helps.

  • gabord13 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 3:00 PM (in response to gabord13)

    Ah and the Library dir is not visible in Lion, so to reach it, You must use Terminal, or in finder use the Go command, then write "~/Library"



  • danloughney Calculating status...
    Currently Being Moderated
    Nov 27, 2012 6:20 PM (in response to gabord13)

    Worked for me as well.  I had a problem starting XCode 4.5 where I mistakenly opened a folder instead of a project from the Welcome window and from that point on I was stuck in a CPU loop.  cd into the folder.  found those xcode files and rm-rf'ed them out of existence.  XCode started right up after that.


    Makes sense that these files survived an xcode reinstall and OS reinstalls.  Would be fixed by installing/running under another user.


    Thanks very much,


  • Locomotivation Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 11, 2013 1:41 PM (in response to EGibs)

    Removing the Autosave alone was not sufficient in my case.

    For anyone still experiencing this stubborn problem, here's what (finally) worked for me:


    First, stop or if necessary kill XCode.  Then do this:


    1. Remove everything under ~/Library/Developer/Xcode/DerivedData

    2. Remove the directory ~/Library/Saved\ Application\ State/

    3. Remove the file ~/Library/Autosave\ Information/ if it exists.

    4. Remove the file ~/Library/Autosave\ Information/Unsaved Xcode Document.xcworkspace if it exists.

    5. Remove any other .xcworkspace files you find there.


    Restart XCode.


    Good luck.

  • BBLApple Calculating status...

    I have the same problem, started using xcode earlier this month, have the latest version, put a project in the trash and have had the white screen stating "no editor" ever since.  Tried Locomotivation's tips above.  Only noticed a couple of files under the derived data folder in step 1 which I removed...couldn't see any of the others mentioned or any .xcworkspace files.  Tried restarting Xcode and had no success.


    Anybody have other ideas?

  • Wraex Calculating status...
    Currently Being Moderated
    Feb 18, 2013 7:28 AM (in response to gabord13)

    Great, worked for me.

  • Wojtek72 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2013 6:15 PM (in response to Wraex)

    After backup from timemachine I had "no editor" message on my screen. The method given by Locomotivation worked for me. Thanks.



  • gwhisenant Calculating status...
    Currently Being Moderated
    May 7, 2013 7:53 PM (in response to gabord13)

    Worked like a charm - thank you!


    I went into terminal and just deleted everything in that folder. As root, type "rm -rf *" IN THAT DIRECTORY ONLY, as it will delete all contents. If you are up a level (or even worse, several) it can ruin you.

  • Joeobinary Calculating status...
    Currently Being Moderated
    Jun 20, 2013 7:19 AM (in response to EGibs)

    Hopefully this alterative will work for some:


    To show the tools on the 'No Editor' pane right-click on the toolbar area beside your project title, this should give a 'Show Toolbar' option.


    On the far right of this toolbar, click the leftmost 'Show Navigator' button in the group of three 'View' icons.


    This should present your project in the navigator on the left for you to access.

  • cydaps Calculating status...
    Currently Being Moderated
    Oct 23, 2013 12:34 PM (in response to Joeobinary)

    You sir (Joeobinary) are a genius!!! So the XCode main screen was there all along, just hiding!!! You saved me a nightmare just hours before a go-live!!!


    Perfect solution, worked instantly and no need to delete files etc etc! Thank you!!!!

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.