Skip navigation

XServe EFI firmware 1.2 fails

739 Views 2 Replies Latest reply: May 9, 2013 3:34 PM by Erics1019 RSS
BergerT Level 1 Level 1 (5 points)
Currently Being Moderated
Nov 29, 2012 12:50 AM

I have an XServe 3,1 (late 2009) running 10.7 where the EFI firmware update fails repeatedly - and as a result is offered every single time the software update is run. I wanted to resolve the problem before updating to 10.8 - and finally Apple repsonded to my bug report that there is a missing file:

/usr/bin/ipmitool

 

Because my other Xserve is a 2,1 hardware running 10.6.8 and it has the file; I did a clean install of 10.6 on my Xserve3,1 (install DVD). Then I upgraded to 10.6.8 (software upgrade).

 

Then I copied the file from my other Xserve2,1 using SCP to the remote Xserve3,1:

scp /usr/bin/ipmitool sysadmin@10.1.1.2:/

 

then I went on the Xserve3,1 and corrected the ownership and moved it to the final location

sudo chown root:wheel ./ipmitool

sudo mv ./ipmitool /usr/bin

 

After copying the file (/usr/bin/ipmitool) from the XServe 2,1 (10.6.8) to the XServe3,1 (10.6.8) the Xserve EFI firmware update (located in /Applications/Utilities) runs fine; and the EFI firmware is now updated to v1.2.

Mac mini, Mac OS X (10.7.2), PEGASUS R6 peripheral
  • ClassicII Level 3 Level 3 (830 points)
    Currently Being Moderated
    Nov 29, 2012 5:55 AM (in response to BergerT)

    Great tip and nice work. Thanks for sharing.

  • Erics1019 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 9, 2013 3:34 PM (in response to ClassicII)

    i Have about 10 Xserve 3,1 and they all are running mountain lion 10.8.3. and on all of them i keep getting the Xserve EFI Firmware Update 1.2 but it doesnloads then i go to utilities folder and double click it and it restarts like it should but it never updates the firmware it just reboots and comes back on and tells me to update again does anyone know how to fic this in 10.8 thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.