Skip navigation

Error -42408 on launch!

751 Views 4 Replies Latest reply: Dec 3, 2012 10:32 PM by kserxes RSS
rootbeerinacan Calculating status...
Currently Being Moderated
Nov 29, 2012 9:53 PM

Hi All!

 

I'm on Mountain Lion, and I have updated iTunes to version 11, didn't like it, and decided to go back. Now I'm getting an "Error -42408" on each launch, while the app and Store both work fine.

 

After doing about an hour of digging, it looks like iTunes gives a -42408 when its having problems talking to the iTunes Store.

 

So far, I have tried:

 

-Removing iTunes.app from the Applications folder and reinstalling.

-Removing /Library/iTunes folder

-Removing ~/Library/iTunes folder

-Removing iTunes preference files in ~/Library/Preferences and /Library/Preferences

-Removing traces of installing v.11, by:

     >Changing InstallHistory.plist in /Library/Reciepts

     >Removing iTunes PLIST and BOM files from /private/var/db/receipts/

-Removing /Users/Shared/SC Info folder

-Using AppZapper to see if I could have missed something

 

...but the error persists.

 

As far as I can tell, there are two possibilities:

1. Some file that iTunes accesses on launch is telling iTunes something it doesn't like. (like an incorrect version number), or

2. Some file that iTunes accesses on launch is telling iTunes what to tell the iTunes Store, and the Store doesn't like what this file has to say.

 

Any ideas? I'm stumped!

OS X Mountain Lion (10.8.2)
  • -Paul Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 29, 2012 10:44 PM (in response to rootbeerinacan)

    my only thought would be going to view my account from itunes then de-authorize all computers then re-authorize. i cant test as i did it once this year.

  • unicorn27 Calculating status...
    Currently Being Moderated
    Nov 30, 2012 1:54 AM (in response to -Paul)

    I have this same problem.  Tried the solution of de-authorising all computers.  However, when I try to re-authorise the computer, I get the same (-42048) error, with a message saying there was an error in the iTunes store.  So this isn't recommended.

  • kserxes Calculating status...
    Currently Being Moderated
    Dec 3, 2012 10:32 PM (in response to rootbeerinacan)

    Hi guys,

     

    I cannot exactly tell you what fixes the problem but it seems that when you just install iTunes 10.7 again it does not overwrite all files which have been altered by the iTunes 11 installation. But following this short tutorial fixed the -42048 error for me:

     

    http://forums.macrumors.com/showpost.php?p=16400819&postcount=6

     

    All kudos go to the original post author bogoss. Hope it helps.

     

    Cheers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.