Skip navigation

iphone 5 Bluetooth streaming to car stereo doesnt have song, artist, controls, etc iOS 6 problem?

38014 Views 41 Replies Latest reply: Jun 27, 2013 10:47 AM by Slamdogg RSS
  • Clark Addison Level 1 Level 1 (15 points)

    My iphone 4 worked fine with my Alpine stereo in my Porsche.  The artist, song, and album showed on the stereo display, and I could pause and skip through the radio controls.  Most of that stopped working when I updated to an iphone 5.  Data no longer displays, and the radio control over the iphone has been lost.

     

    According to the stereo installer, other stereo brands are also affected, and Alpine is supposed to be working on a firmware fix.  I hope it's soon.

  • Lars Hilse Calculating status...

    Same issue here with the newest Kenwood BT-Receiver.

     

    After having spoken to Kenwood about these issues I got into a discussion with the quite knowledgable call center agent about how Nokia intended to re-define the Bluetooth-Standard back in the day and how this failed attempt put the massive dent into Nokias (then) very convinced and utmost loyal user-base.

     

    Very sad to see the similarities in these two cases and getting ever more disappointed in Apple.

     

    Obviously, Apple is also neglecting the numerous requests by car-stereo manufacturers to sit at a table and speak with them about how to solve this very wide spread issue.

  • ggw777 Calculating status...

    So... another one. I have a built in BOSE System, that was really something you love while driving, and with my 3GS it was indeed lovely. Yesterday I got my Iphone 5 and... well.. no more concert feeling, since I can not connect via bluetooth, as all the other guys described here. The connection works at least via the built in USB port, I can play the songs and so, but the control via car screen is not possible, and as someone mentioned before, it might be risky on the highway if you tap on the phone while driving.

     

    But... why do we post all this here, when no one from Apple is going to answer? Or will they?

  • Lageorges Calculating status...

    I have an aftermarket unit...the phone connects via BT ....but no tunes or control .... all worked before ...

  • Grace212 Calculating status...

    Not sure if people are still having this problem, but I happened across a solution yesterday by accident.

     

    I have an iPhone 4S and did the update. Streaming music via Bluetooth in my car was a lot more spotty and sound quality did go down. One day the song information stopped appearing on the car unit screen and I was no longer able to control music on my iPhone with my steering wheel controls. I could adjust the volume, but nothing else.

     

    I recently got some headphones for Christmas. Similar issue. The headphone controls worked only for adjusting the volume. I could not pause, play or skip tracks with the headphone controls. I found the following solution in another Apple Support Community blog:

     

    Plug in headphones. Go to Settings>Music>Volume Limit. Slide the volume limit down then slide it all the way back up. Then restart phone.

     

    My headphone controls worked after I did this. Surprisingly, when I got in my car the next day, everything was back to working order. All steering wheel controls worked and song information was displayed.

     

    Seems the issue with the car controls and headphone controls are somehow related. Anyway, give this a try if you are still having problems.  It worked for me.

  • versiera Calculating status...

    I have an iPhone 5, IOS 6 and also am not able to stream music from the iphone 5 to the 2011 Audi A4 using Bluetooth. I hope Apple can fix this issue.

  • Hongkongee Calculating status...

    My iPhone 4 Bluetooth worked well with my Lexus.  My iPhone 5 Bluetooth worked well for the phone with my Lexus but music cannot stream via Bluetooth.  Very frustrating. 

  • crh24 Level 3 Level 3 (920 points)

    This post may or may not help some of those with Bluetooth problems on a Pioneer Head unit...

     

    I have never had a problem with Bluetooth on my Z140BH.  Everything has worked as it should beginning with iOS 5.x on an iPhone 4S and continuing to 6.0.x on an iPhone 5.  No problems at all.

     

    When I updated my iPhone 5 to iOS 6.1, however, that all changed.  Nothing worked correctly via Bluetooth.  The handsfree wouldn't even pair and the audio portion worked--sometimes--but was really unstable.  Neither of these symptoms had ever happened to me prior to the update to iOS 6.1.

     

    I tried everything I could think of to get the Bluetooth to work, hard resetting the iPhone, 'forgetting' and re-discovering the connection on the iPhone, changing the profile on the Z140BH, etc., but I had no success until I bit the bullet and did a factory reset on my Z140BH.  After the factory reset everything worked as it should--again without any problems at all.

     

    My guess is that somewhere along the line the Z140BH Bluetooth setup became corrupted and the factory reset cleared it out.  I did have to spend a few minutes setting up my head unit again, but that was a small price to pay for having the Bluetooth work properly again.

    iPhone 5, iOS 6, iPad '4' 64GB AT&T (2), iPad 2
  • DRDRJAY Calculating status...

    Hmm...have to put my 2 cents in here!  I have a 2012 Audi A7, full Bose setup, etc. and a 64 GB iPhone 5 with all the issues as described in various ways above.  My Music does stream beautifully..always...it's just the d*** display with the Artist, Song, Title info.  Just upgraded to IOS 6.1.3 and thanks, Salem, a hard reset does work wonders.  The Audi has copied my whole contact list so the dislpay always shows who's calling, their number, etc. and the dislpay shows two rectangular buttons for answer and end call.  I'm saying this because the Artist, Song, Title info always comes back after I answer and end a call this way!! ??? No clue why.

    Gotta love those Germans!  The Bluetooth & Wireless internal modems will reset themselves by....opening the driver door for ten minutes, then closing it__little switch in there somewhere. Geez!  Soo, some of the time I can get both the Music and the Display working at the same time.  The other day, my Audi lost its Bluetooth connection and the display showed it was resetting itself.  Afterwards--guess what?-- Display and Music started working again and for the whole day!

     

    The bad news for the Audi is---Bluetooth and Wireless are handled by T-Mobile ( Oh No! )  Talked with T-mobile at length -- several departments -- and basically they said that the iPhone 5 is too new a phone and their software has not been updated for it yet! [And they don't know when ] ( But it is 100% compatible with the iPhone 4 )

     

    Guess that's 10 cents worth :-)

  • DaveAtlNE Calculating status...

    I had the same problem with an Alpine deck. I tried a couple of the suggestions in this thread, but they did not help. I eventually found my answer here:

     

    http://support.apple.com/kb/TS4483

     

    My deck supported the AVRCP 1.3 profile for remote-control of audio playback, but iOS 6 uses the 1.4 profile. I was able to upgrade the Bluetooth firmware based on information I found here:

     

    http://alpine-usa.com/feeds/promo/13hubtupdate

     

    After the upgrade, song titles were back, and I could once again control playback from the deck.

     

    Hope this helps.

  • Slamdogg Calculating status...

    I had the same experience. I went to the alpine website and downloaded the firmware update and followed the instructions.

     

    The Alpine instructions are detailed and easy to follow, and problem solved.

     

    The download is hard to find, click on the support tab and then click on find an owner's manual(???) and type in your model number. You'll get several links back one will be for the firmware download.

     

    This will require a laptop that you can take to the car.

     

    good luck.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.