Skip navigation

IChat refuses to sign in sometimes, only solved by rebooting (not ideal)

289 Views 1 Reply Latest reply: Nov 30, 2012 1:30 PM by Ralph Johns (UK) RSS
197six Calculating status...
Currently Being Moderated
Nov 30, 2012 5:24 AM

Two of my users have been experiencing this recently. Their iChat sessions (one XMMP and one Google account each) sign out and they cannot sign them back in, shutting down and relaunching makes no difference. After a reboot though, iChat signs in and works. This only happens after a few weeks without a reboot but these are Macs and not Windoze machines that want a reboot every day so my users do not want to have to reboot to fix the problem.

 

There is obviously some service that iChat is dependent on that is wobbly - can anyone offer an suggestions?

 

TIA

Simon

Mac Pro, Mac OS X (10.7.5)
  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)

    Hi,

     

    A Jabber login happens on either port 5223 or port 5222 depending if SSL is being done or not.

     

    Googletalk uses port 5223 as it normally use SSL to connect.

    If the server is dropped (or drops you) then iChat or Messages needs that connection reset.

    In most cases this can be done by unticking the "Enable the Account" box in the Account info tab (App Menu > Preferences > Accounts).

     

    I have found you can change the port to the Google (talk) server to 443 and it will be accepted.

    you have to change this whilst logged out.

    I find this does not seem to drop the connection as frequently as the regular port.

     

    For other Jabber servers it can be more difficult to find a port that works.

    Most do not allow a Non SSL login (Port 5222).

    It can be trial and error to see if they will accept a port such as 443  in place of port 5223.

    (443 is used for Secure site Web Browser logins like Banks and the Login process here at Apple Support Communities and also by some mail servers)

     

     

     

    Sigcopy2.png


    9:29 PM      Friday; November 30, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.