12 Replies Latest reply: Nov 30, 2012 8:10 AM by jimmyhurt
senatorakuezue Level 2 Level 2 (265 points)

Hey, so I have set up my VPN configuration, and everything seems to work, except for iChat for some reason. I have it set up with my Google account, and I've tried changing the port # to 443, but to no avail. Any suggestions? I haven't seen this to be an issue on these forums, so I assume that it's only me... which means that it should work? Thanksfor the replies in advance!


MBP 2.2 GHz, 2 GB Ram, 120 GB HD, Mac OS X (10.7)
  • 1. Re: iChat not working with my VPN
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    Hi,

     

    I have seen one other Thread in which when adding in or starting a VPN causes iChat in Lion to Fail.

     

    I have known for a long time that iChat needs to have one IP only.

    Connecting Wifi and Ethernet will cause issues when it comes to Audio Only or Video Chatting.

    (iChat 1 through 5 seems to cope with a double Internet Connection during the Login and Text chatting parts).

     

    There was an issue in Leopard (OS X 10.5.x/iChat 4.x)  where, if you turned On System Preferences > Sharing > Internet Sharing then that computer's iChat could also "See" the Internet Connection of the Shared Device.

     

     

    I have never created a VPN for myself and would be lost in suggesting any steps to take.

     

     

     


    9:06 PM      Tuesday; August 23, 2011


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb( 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: iChat not working with my VPN
    senatorakuezue Level 2 Level 2 (265 points)

    Hello, I posted this question about a month ago and, with no solution, I figured I'd only repost with an update. Well, I logged onto my VPN (for library research purposes) and my iChat for the first time did not log me out of goggle chat. I can't specifically explain what has happened, but it does seem to be working. I don't have much time to dig around any further for answers, as graduate classes started last week and I'm buried, but it DOES work (or seems to, at least: I've not tried talking to anyone yet). It would seem strange that it would working in 10.6 but suddenly stop working in 10.7. I'll keep updating as things change.

  • 3. Re: iChat not working with my VPN
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    Hi,

     

    Understood.

     

    As a side Note I am having trouble getting my son's MacBook Pro to access a NAS Drive as a windows Share properly.

    It can "See" the Device but it keeps saying he does not have permissions to access it it properly.

     

    (He does if we log his account in from another computer (Windows 7, Snow Leopard and Leopard)

    So it does seem that are differences in Lion.

     

     

     


    3:59 PM      Monday; September 26, 2011


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb( 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 4. Re: iChat not working with my VPN
    paulpangrazzi Level 1 Level 1 (0 points)

    Unfortunately, it's not just you... It's been a known issue for many of my colleagues at work (when we VPN into the office.) In fact, it's happening right now on my personal iMac with Lion.

     

    To make matters more frustrating, it DOES work occasionally. My unscientific feeling is that it's successful about 10-20% of the time. I tried various activities such as initiating a chat before signing into VPN, quitting and restarting iChat during a VPN session, etc. In the end, I can't figure out why iChat connects, or doesn't.

     

    BTW, this behavior extends from Lion to Snow Leopard, to Leopard... it doesn't matter what OS, it's just as random. Most of my co-workers have switched to another chat client called Adium, which I'm about to do today.

  • 5. Re: iChat not working with my VPN
    studiodave1 Level 1 Level 1 (0 points)

    We stumbled across this thread looking for the solution. In our case, we are trying out a new Cisco router. When we used the built-in client to connect to a remote VPN, iChat was dropping the connection. The problem was solved by enabling remote management on the new Cisco router. Cisco uses port 443 for remote management, and if you have it disabled, the port is somehow blocked or rereouted when a VPN connection is established.

    Please keep in mind that you'll want a strong password for your router management if you enable this feature.

  • 6. Re: iChat not working with my VPN
    anuj.agrawal Level 1 Level 1 (0 points)

    Facing the same problem of not being able to get iChat to work while connected to VPN

     

    Help, anyone please?

  • 7. Re: iChat not working with my VPN
    Brent.Salisbury Level 1 Level 1 (0 points)

    Bump. Anyone seen a fix for this? First class ticket to nerdrage at this point.

  • 8. Re: iChat not working with my VPN
    Ralph Johns (UK) Level 9 Level 9 (67,500 points)

    Hi,

     

    I have nothing new on the VPN issue.

     

    On the NAS drive.

    It seems that some have firmware that is only suitable up to and including Snow Leopard.

    In some cases it is impossible to get new firmware for those devices, effectively making them obsolete.

     

     


    8:33 PM      Monday; June 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 9. Re: iChat not working with my VPN
    senatorakuezue Level 2 Level 2 (265 points)

    Apparently it's been almost a year since I've posted about this. Nothing has changed since my latest update, except for the fact that I've had about 80% success rate with logging in to my university's VPN with my iChat logged into my Google Talk account.

     

    Then, about two weeks ago I upgraded my mid/late 2007 MBP to a Retina MBP. Upon setting up my VPN account (I didn't do the migration as I wanted to start 100% fresh), my success rate has been very spotty once again. Not sure what to make of it, but that's all I have. Luckily for me, I only really do my electronic library research at night, and since I've moved three time zones to the west, my friends aren't really awake to talk to that late at night anyway.

     

    In any event, I'm bumping this thread to see if anyone else has had any changes in status.

  • 10. Re: iChat not working with my VPN
    mrj00 Level 1 Level 1 (0 points)

    Anytime I get disconnected from the VPN (and my chat session is disconnected), I have to go into the preferences for the connection, change the server name, attempt to connect, then change it back.

     

    Seems to be some kind of caching, even though restarting iChat doesn't help.

     

    Very annoying...

  • 11. Re: iChat not working with my VPN
    Mark23 Level 3 Level 3 (975 points)

    When you start a VPN connection, your client receives information from the server, one of which is the DNS server to use for that connection. Probably this is an internal server (perhaps on the same server?) in which case you should set up forwarding to other DNS servers like Google's (8.8.8.8 and 8.8.4.4) for queries for which your server is not authoritative.

     

    On Lion I think it's somewhere in Server Admin.

     

    This is all server side.

  • 12. Re: iChat not working with my VPN
    jimmyhurt Level 1 Level 1 (0 points)

    I believe that I have hit upon the solution to this problem, at least for me.

     

    While connected to my VPN at the office from home ( wireless network from Xfinity cable modem connection), I checked the VPN settings in System Preferences.  I clicked on Network, then VPN, then Advanced.  There is a tab for DNS, and I noticed that I did not have any DNS settings in there at all.  I added the Google DNS server (8.8.8.8), and restarted my iChat.  Viola!!  I hope that this works for you guys as well.