Skip navigation

Printing on a Laserjet 4240n over the ethernet.

197 Views 6 Replies Latest reply: Dec 3, 2012 7:41 AM by John Galt RSS
akubraman Calculating status...
Currently Being Moderated
Nov 30, 2012 8:27 AM

We just upgraded from a Linksys wireless g router to an Airport Extreme wireless n (5th generation, model A1408).  This Laserjet printer only has an ethernet port (and a parallel but we've never used it) which worked fine for printing over the Linksys.  How can I get it to work with our new AEBS?  I seems to recognize that the printer is there in system preferences (I've exchanged files between computers and can get on the internet so I know that Airport is functioning) but when I send a print command to the printer it just hangs.  I'm using an iMac in 10.8.

 

The only other information I can provide is that in order for us to have a stable internet connection we have to have the AT&T DSL modem configured to NOT be in bridge mode (when it is, the internet connection would drop anytime we demanded too much info through our browser).  Therefore the AEBS is set up to connect via DHCP and not PPPoE.  That said, under the network tab in the Airport Utility, the router mode is set up in DHCP & NAT (of which I know very little) instead of Off (Bridge Mode).  We do have a double NAT warning but it doesn't seem to affect browsing speed and maybe this is the problem?  With the modem configured as it is, if the AEBS is placed in Off (Bridge Mode) I cannot connect to the internet but CAN get the laserjet to print.  Any help would be appreciated.

iMac, OS X Mountain Lion (10.8.2)
  • John Galt Level 7 Level 7 (33,065 points)
    Currently Being Moderated
    Nov 30, 2012 8:48 AM (in response to akubraman)

    Changing your router is like a heart transplant for your network. Everything changes.

     

    Generally speaking, for printers connected via Ethernet, you go to System Preferences > Print & Scan, and click the + (plus) button. Most of the time the printer is found automatically.

     

    If that does not work, click the IP pane, select "Line Printer Daemon", supply the printer's IP address, the queue name (this is optional unless you are using a print server), and the name you would like to give the printer - any human-readable name you choose. "Location" is optional. For "print using", click "select printer software" and scroll through until you find the appropriate driver.

     

    When you are done it ought to look something like this:

     

    664479ffccc27f9622ed79c59a4f1cc7.jpeg

    Click Done and the printer will be added to your printer list. Next time you print, select that printer.

     

    Delete the earlier one in Print & Scan.

    MacBooks  iMacs  iPods  AirPorts, OS X Mountain Lion,  27 years Apple!
  • John Galt Level 7 Level 7 (33,065 points)
    Currently Being Moderated
    Dec 1, 2012 6:22 PM (in response to akubraman)

    You need to assign the printer an IP address available to your LAN.

     

    Linksys routers default to assigning IP addresses in the range 192.168.x.x. Apple AirPort base stations default to 10.0.x.x. I don't know what AT&T uses.

     

    If you did not change that, you must either change your router's addressing scheme, or the printer's, so that all your network equipment is on the same subnet.

     

    To determine if your printer is available on your LAN you can use Terminal - Terminal is in your Mac's Utilities folder. Open Terminal and type

     

    ping

     

    ... followed by the IP address of your printer.

     

    For example, if its IP address is 10.0.1.100 you would see output like this

     

    Johns-iMac:~ john$ ping 10.0.1.100

    PING 10.0.1.100 (10.0.1.100): 56 data bytes

    64 bytes from 10.0.1.100: icmp_seq=0 ttl=255 time=5.478 ms

    64 bytes from 10.0.1.100: icmp_seq=1 ttl=255 time=2.461 ms

    64 bytes from 10.0.1.100: icmp_seq=2 ttl=255 time=2.489 ms

    64 bytes from 10.0.1.100: icmp_seq=3 ttl=255 time=2.841 ms

    64 bytes from 10.0.1.100: icmp_seq=4 ttl=255 time=2.793 ms

    ^C

    --- 10.0.1.100 ping statistics ---

    5 packets transmitted, 5 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 2.461/3.212/5.478/1.143 ms

    Johns-iMac:~ john$

     

    Press control c to terminate the ping requests.

     

    On the other hand if you see output like this

     

    Johns-iMac:~ john$ ping 10.0.1.101

    PING 10.0.1.101 (10.0.1.101): 56 data bytes

    Request timeout for icmp_seq 0

    Request timeout for icmp_seq 1

    Request timeout for icmp_seq 2

    Request timeout for icmp_seq 3

    ^C

    --- 10.0.1.101 ping statistics ---

    5 packets transmitted, 0 packets received, 100.0% packet loss

    Johns-iMac:~ john$

     

    ... then the printer does not exist on your LAN. You won't get to step 1 until it is.

    MacBooks  iMacs  iPods  AirPorts, OS X Mountain Lion,  27 years Apple!
  • John Galt Level 7 Level 7 (33,065 points)
    Currently Being Moderated
    Dec 3, 2012 7:41 AM (in response to akubraman)

    ... some reason my Macbook Pro doesn't automatically recognize the Airport Wi-Fi network (either here or at my home).  I have to manually use the pull down menu and identify the network for it

     

    This annoying problem arose after an earlier OS X updates. Subsequent updates fixed it for most people, but it still exists for some others. The cause remains elusive.

     

    The only thing I can suggest is to go to System Preferences > Network > Advanced button, and remove (forget) all the networks that appear in your "Preferred Networks" list. Click OK, then return to the Network preference pane and click the "gear" icon at the lower right. Select "Set Service Order..." from the contextual menu, and re-order the network services that appears. The order itself is unimportant for now. Click OK, then Apply.

     

    The idea is to reset your network preferences. This may or may not result in any improvement, and even if the problem disappears it may reappear in the future.

     

    Other mysterious fixes alluded to Bluetooth interference. Try turning Bluetooth off on the MacBook Pro.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.