Skip navigation

Consistent error when trying to install Command Line Tools

345 Views 5 Replies Latest reply: Nov 30, 2012 12:14 PM by Wayne Contello RSS
sbFromMd Calculating status...
Currently Being Moderated
Nov 30, 2012 8:11 AM

Hi there,

 

after downloading XCode from the App-store without problems, I then tried to add the Command Line Tools via the Preference/Download/Components menu.

When it comes to install the downloaded package, Xcode states "An error occured while extractng files from DevSDK.pkh", and thats about it. Re-installed Xcode, same result. Downloaded the image for the CL-utilities by hand, several versions including older ones, with the same result. The error message in /var/log/install is not very enlighning (for me)

 

NSUnderlyingError = "Error Domain=BOMCopierFatalError Code=1 \"The operation couldn\U2019t be completed. FinishStreamCompressorQueue error\" UserInfo=0x7ff9e1ec9ae0 {destinationPath=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandboxManager/1.sandbox/Root, offset=1156350, type=BOMCopierFatalError, sourcePath=/var/folders/2f/vqq1hf8d0851_5ty12s5g0ym0000gp/T/attached-image-2b66 48c01a1f4d20c9a96b45cf50d1e78e216eb4/Command Line Tools (Mountain Lion)/Packages/DevSDK.pkg, NSLocalizedFailureReason=FinishStreamCompressorQueue error}";

        PKInstallPackageIdentifier = "com.apple.pkg.DevSDK"

 

 

I am a bit stuck here (and in desperate need of a c++ compiler). Any suggestions what to do ?

MacBook Pro with Retina display, OS X Mountain Lion (10.8.2), Xcode 4.5.2
  • Wayne Contello Level 6 Level 6 (12,650 points)

    1) How much disk space do you have?

    2) have you rebooted?

     

    as a last suggestion you could try deleting (although I am not certain about this option):

     

    /var/folders/2f/vqq1hf8d0851_5ty12s5g0ym0000gp/T/attached-image-2b66 48c01a1f4d20c9a96b45cf50d1e78e216eb4/Command Line Tools (Mountain Lion)/Packages/DevSDK.pkg

     

    and

     

    /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandboxManager/1.sandbox/Root

  • Wayne Contello Level 6 Level 6 (12,650 points)

    you can use the terminal to check for these folders.

     

    To open the Terminal navigate to the folde "/Applications/Utilities/"

     

    double clcik "Terminal"

     

    Here is a listing on my machine (bold is what I typed):

    Proton:~ wayne$ cd /var/folders/

    Proton:folders wayne$ ls -al

    total 0

    drwxr-xr-x   8 root  wheel  272 Sep 15 16:11 .

    drwxr-xr-x  27 root  wheel  918 Aug 23 14:37 ..

    drwxr-xr-x   3 root  wheel  102 Aug 23 14:46 7h

    drwxr-xr-x   3 root  wheel  102 Aug 23 14:43 db

    drwxr-xr-x   3 root  wheel  102 Sep 15 16:11 jj

    drwxr-xr-x   3 root  wheel  102 Aug 23 14:57 qq

    drwxr-xr-x   3 root  wheel  102 Aug 23 14:57 vy

    drwxr-xr-x  22 root  wheel  748 Sep 15 16:13 zz

    Proton:folders wayne$

     

    you can type "cd /var/folders/zz" to get to one of the folder (if it exists).  If the folder does not exist then I would try logging in as another user and attempt to install from there

  • Wayne Contello Level 6 Level 6 (12,650 points)

    the last entry in the list you provided is "zz" so ...

     

     

    if you look at the second path in the error message (bolded)...:

     

    /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandboxManager/1.sandbox/Root

     

     

    you will see that the path matches.  If you don't feel compfortable navigating via the terminal you can also navigate via the finder and go directly to this folder by selecting the menu item "Go > Go To Folder...":

     

     

    Screen Shot 2012-11-30 at 2.05.03 PM.png

     

    then enter the path "/var/folders"

     

    you will see the "zz" folder in there.  you can open that and continue until you can see the folder "zyxvpxvq6csfxvn_n0000000000000"

     

     

    Here is view from the terminal and the Finder of the same structure:

    Screen Shot 2012-11-30 at 2.08.14 PM.png

     

    I have that same folder:

    Screen Shot 2012-11-30 at 2.12.28 PM.png

     

    select this folder and delete (I think you will have to authenticate to remove).... sorry I am not going to remove since things are working on my end.

     

    locate the other folder and do the same.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.