Skip navigation

An unknown error has occurred app store

172570 Views 166 Replies Latest reply: Mar 13, 2014 10:44 AM by matt.m.edwards RSS
  • Hesekiel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2012 4:28 AM (in response to OlofMork)

    I have encountered this problem too. I have tried various suggestions I've found on the web. I have also made a system recovery - but nothing have worked. Still the same old message: "an unknown error has occurred", whenever I try to sign in on App Store.

     

    I've contacted the App store support - the last thing I heard from them was that they were investigating the issue (this was about two weeks ago now).

     

    I run OSX 10.8.2 on a Macbook Air 11" (bought in July 2012). I can still use App Store on my old Macbook (Snow Leopard). Itunes works fine - it's only App Store that I can't access.

  • rogbos Calculating status...
    Currently Being Moderated
    Oct 27, 2012 6:29 AM (in response to Hesekiel)

    I have the same problem. I have a MacBookPro upgraded from Lion to Mountain Lion and no problem with my AppleID for Icloud, MacAppStore, FaceTime and iTunes. But using the same AppleID on the Imac upgraded also from Lion to Mountain Lion, the MacAppStore dont accept login, alltime i have the unknown error. Icloud, iTunes and Face Time working correctly. I've contacted Apple support and i've tried to move cache.db, com.apple.appstore.plist and com.apple.network.identification.plist to trash and then restart and try login on App Store, but it doesn't help. For making updates for apps on the Imac I must work now with a second user with administration rights, and I also used the same Apple ID for login on the App Store, and the App Store works correctly. I've looking on different communities, but I dont find the solution.

  • 90studio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2012 11:54 AM (in response to rogbos)

    But did you try this: go to Library/Preferences/SystemConfiguration and then delete 'NetworkInterfaces.plist'

     

    I noticed that you've deleted network.identification.plist & appstore.plist, but not the NetworkInterfaces.plist.

     

    Let me know if this works.

  • rogbos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 28, 2012 5:24 AM (in response to 90studio)

    Thanks for the suggestion, but after deleted NetworkInterfaces.plist, always the same problem.I'ts very space because on the MacBookPro I've exactly the same configuration (I've compared settings many times for be sure) and there is not a problem with the Mac App Store on the Mac Book Pro.

  • Hagber Calculating status...
    Currently Being Moderated
    Nov 13, 2012 1:57 AM (in response to OlofMork)

    Hello all together,

     

    I've solved my problem which is - so I think - identical with your problem.

     

    That's the way I've taken:

    I've downloaded the program "Mac Cleanse" (I've got a free licence because of an advertisment. Here is the link: http://www.koingosw.com/promos/appyfridays.mc/)

     

    after I have installed the programm I scanned my mac. The program did find a lot of files. I deleted them all.

    Result: I've downloaded the first app from the App Store yesterday. :-)) Everything is ok.

     

    I don't know whether this way is good for everyone but for me it was.

     

    Best wishes and good luck!

    Hagber

  • wagaya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2012 5:27 PM (in response to Hagber)

    Sounds worth a try... but when I tried, and let Mac Cleanse freely delete everything it found, it didn't solve the problem. Still no App Store for me. : (

     

    Glad it worked for you, anyway!

  • wagaya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2012 4:05 AM (in response to OlofMork)

    Hey, what's this? Suddenly, today, the App Store works perfectly for me. I didn't do anything new; I just tried to install an app update on a whim, and it worked. New download/installation works too.

     

    Since I did nothing on this end, it suggests to me that Apple quietly fixed something on their end. Anyone else able to confirm a fix?

  • jb2683 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2012 5:41 AM (in response to OlofMork)

    can confirm that the app store works again! didn't do anything and as of today it works :-)

  • anonyhosking Calculating status...
    Currently Being Moderated
    Nov 29, 2012 1:17 PM (in response to jb2683)

    Yep, works for me now as well.

    So, now I want to know what Apple did to fix the issue, since it seemed to be something to do with my account on my laptop (i.e., somewhere in ~/Library/...).

  • zphelj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2012 3:19 PM (in response to wagaya)

    It's still not working for me on 10.6 Mac Mini. I installed the latest iTunes update and rebooted.

  • George Katele Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 12:04 PM (in response to OlofMork)

    All of a sudden, working for me as well (Late 2009 iMac, Mountain Lion 10.8.2). As I was told when I called about the original issue, "there's a problem at our end." Guess they fixed it.

  • rogbos Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 30, 2012 12:11 PM (in response to wagaya)

    Yes, I can confirm. After typing the login the App Store shows my account and credit card data and asked to confirm the security code from my credit card, then everything works. But now it would be great to know about the reason because since weeks i've tried everything without succes.

  • PatrickL Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 3, 2012 10:12 AM (in response to OlofMork)

    I am trying to download Mountain Lion again so that I can make a bootable USB stick. However, I get the following error (the image is rather small; it say 'An error has occurred' and the DOWNLOAD button is just a gray box without any letters in it) displayed in the App Store. I've tried deleting the Cache.db and cookie files for the App Store, logged out and logged back in, called a psychic hotline, put my MacBook Pro in the freezer for 17 minutes...to no avail.

     

    ml-error.jpg

  • agilityvision Calculating status...
    Currently Being Moderated
    Jan 2, 2013 4:12 PM (in response to Andreas Amann)

    Here is a step-by-step of what worked for me:

     

    1. Create a new user account - let's name it "Test" - I did not make this an administrator account
    2. Log into that new user account (skipping the AppleID/iCloud screen)
    3. Select "Software Update…" from the Apple menu - you will be asked to enter an administrator name and password in or to check for system updates - just provide your normal (admin-enabled) user name and password
    4. If you have any updates available, click "Update All" and log into the AppStore with your normal AppleID/password (this should work since you are in a new user account)
      (If you don't have any updates available, I assume that you can also log in using the menu item in the Store menu of the AppStore application though I have not tried that)
    5. As soon as the download starts, you can quite the AppStore application
    6. Log out of your test account and back into your normal account
    7. Open /Applications/Utilies/Terminal
    8. Type the following command:
      sudo cp  /Users/test/Library/Cookies/com.apple.appstore.plist Library/Cookies/
    9. Open the AppStore again and you should be able to log back in

    this worked for me, only addition is I had to log in as super user / root in order to copy the file, and then chown (change owner) the file to my user name

  • Brian Herwood Calculating status...
    Currently Being Moderated
    Jan 10, 2013 3:16 AM (in response to mohd hatta)

    It works! Macbook Pro retina 13" - hey. are you THE Mohd Hatta from Yogyakarta, Indonesia? If so, hi, it's OB.

1 ... 4 5 6 7 8 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.