Skip navigation

Unable to export any photos in 3.4

1178 Views 13 Replies Latest reply: Nov 30, 2012 2:25 PM by SB7523 RSS
SB7523 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 29, 2012 4:31 PM

I am at a loss - been unable to export any photos via the File>Export>Versions or Originals option in Aperture 3.4.

 

This seems to have happened after I upgraded to the most recent version of Aperture, but I'm not 100% sure this is the problem.  I have tried exporting a single photo and multiple photos.  Every time I get an error dialog box, Export Results, that states "Export Versions Complete with Errors".  I then states 0 of 1 file has been exported (the 1 changes based upon how many I've attempted to export).  Below that it states "The export operation failed to create a file for the version identified below".  It then lists the filename of the image I attempted to export.

 

I've tried removing, then reinstalling Aperture through the App Store - no luck.

 

On a side note, I used iPhoto to export the photos from my Aperture library, and it works fine. 

 

Thanks for any help on this!Error.jpg

MacBook Pro (Retina, Mid 2012), Mac OS X (10.7.5)
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Sep 29, 2012 7:10 PM (in response to SB7523)

    Have you tried exporting to different folders on your drive? Where are you exporitng to?

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Sep 29, 2012 7:25 PM (in response to SB7523)

    Always the same message?

     

    You'll need to look in the Console logs to see if the system is reporting any errors when you try to export. The Console app is in the Utilities folder located in the system Applications folder.

     

    When you open it select the first entry in the System Log Queries column, 'All Messages' then select 'Clear Display' from the menu bar.

     

    Now try the export from Aperture and see if anything shows up. Report back.

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Sep 30, 2012 11:20 AM (in response to SB7523)

    Nothing in the logs looks like it applies here. What happens if you drag  an image out of Aperture and place it on your Desktop. This will only be exporting the preview but might supply some information concerning your problem.

     

    Also what preset are you using? Are you trying to export JPGs or TIFFs or ?? Have you tried different presets and file types?

     

    Finally where is the library and masters stored? Are the masters managed or referenced?

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Oct 17, 2012 2:58 PM (in response to SB7523)

    When you didn;t post back I assumed the problem resolved itself.

     

    You're next steps are to make a new empty library import a few images into it and try the export. If that still fails make a new user and again make a new empty library, import and then try the export.

     

    As to your question about any Apple techs here. No this is a user to user forum if you require help from Apple you'll need to contact Apple directly.

     

    regards

  • léonie Level 8 Level 8 (46,540 points)
    Currently Being Moderated
    Oct 18, 2012 12:26 AM (in response to SB7523)

    So, with my limited OS X experience, does this mean I have a corrupted user account?  I have done all my work under this account, so it seems that it would be a lot of work to do everything under another account.  Is there some way to start a clean slate under my current account with aperture?  As always, any help you can provide would be great!

    Just a short answer, till the sun rises in Florida and Frank can be back to this thread:

    It means, that one of the different settings between your user account and a new user account may be causing this. Possible reasons:

    • Permissions and ownership settings in your user account. If you do not own files in your user library or they have the wrong permissions, Aperture may be unable to access or modify the files.
    • Corrupted Preferences and preset files (export presets, raw decode presets, file naming presets) in your user library.
    • Corrupted caches
    • Non standard helper applications you are using (export plug-ins, haxies) or launching as start-up items.

     

    Things to try:

     

    Good Luck

    Léonie

    MacBook Pro, OS X Mountain Lion, 2.4 GHz I.Core i7, 16GB RAM, 500GB
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Oct 18, 2012 9:41 AM (in response to SB7523)

    Glad we made some progress. What this means is that something unique to your account is causing the problem. This usually comes down to a file or files in your ~/Library folder, hopefully it will be an Aperture related file as this will greatly simplify things.

     

    Léonie covered it pretty well, doing the steps with the Aperture preference files is a good place to start. As is the boot into single user mode.

     

    Just a few additional thoughts:

     

    Is your primary account an Admin account? If not was the test account made as an Admin account?

     

    I asked and you answered that you had tried exporting to different folders, are the folders you're trying to export to on the internal drive or on an external?

     

    When you exported using the test account you of course not   export to a folder in your original accounts user area. Was there a common folder that you did export to that worked with the test account but not with your user account?

     

    One other test  try to export from each account to /Users/Shared what happens.

     

    regards

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.