4 Replies Latest reply: Dec 2, 2012 2:04 AM by MariaT
MariaT Level 1 Level 1 (0 points)

I bought a HP office jet 7500A  E910 saying it works with Mac 10.6. Normally it shows the minimum requirements, but here the maximum, means 10.6 and lower! The HP support and driver download site says it comes with Apple updates but I read at Apple support page it doesn't come any longer with Apple updates, so what to do now? Where do I get the update for the printer?

thx,

JD