Skip navigation

How do I run users from an external hard drive?

351 Views 13 Replies Latest reply: Dec 2, 2012 9:25 AM by Eric Root RSS
Gib Van Ert Level 1 Level 1 (15 points)
Currently Being Moderated
Dec 1, 2012 9:24 AM

I used to have a 2 TB hard drive in my iMac. One of the users contains all my music, photos and videos. It's a very large file, of course.

 

I have just swapped out the 2 TB drive for a 120 GB SSD and reconnected the 2 TB drive as an external HD. The problem is, I've only got 60 GB of space left on it and that's not enough room for my media user. It's sitting on the external drive but I can't figure out how to access it.

 

I would like to be able to (1) run the media user from the external drive or, if that's not possible, (2) move the media user to the SSD but store the music, photos, video etc. on the external HD.

 

Any tips? Thanks!

  • Eric Root Level 6 Level 6 (13,860 points)

    I'm not sure I understand the term media user (it is one of your accounts?).

     

    I have a very large iTunes collection on a networked hard drive. I made an alias of the folder and put the alias in the music folder on my Mac. When I start iTunes it goes to the networked hard drive to get the music, apps (iPad), and so forth. The network hard drive does need to be mounted in Finder.

     

    Maybe you could set up something similar.

  • Eric Root Level 6 Level 6 (13,860 points)

    You are welcome. If the tip works, please post so I know.

  • Eric Root Level 6 Level 6 (13,860 points)

    I am not suggesting you move the media user to the SSD. I understand it is too big. Create a new media user account on the SSD in System Preferences, and then place the alias in the new account Music folder. You will need to remove the new user link to iTunes in the Music folder before putting the alias in. You also need to open iTune's preferences, go to the advanced tab, and in the top box point it to your external drive.

     

    iTunes may spend what seems like forever updating itself.

     

    If I could figure out how to make a screen shot, I'd post it. I'm currently working in SL (my hard drive has a SL and a ML partition) and Grab isn't making an image I can post.

  • Eric Root Level 6 Level 6 (13,860 points)

    I don't know if the same thing will work for iPhoto since I don't use iPhoto. If you don't report it does work, I'll load iPhoto and try it (I have iLife '11).

  • Eric Root Level 6 Level 6 (13,860 points)

    I'm glad it worked. If you mark the thread as "This solved my question" I think it tends to stand out more. When I refer people to threads, I usually start with the solved ones. Obviously, that is an opinion.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.