8 Replies Latest reply: Dec 2, 2012 10:23 AM by CedricH
ellisonjay Level 1 Level 1 (0 points)

My 2011 MBA, and 2009 MBP both have problems with sleep, and waking. The MBA no matter what kind of sleep it goes into it wakes with a blank screen. Using deep sleep on my MBP it reboots when it completes wake up. (aka crash) Otherwise I can hibernate that one.

 

Oh if you attempt to deep sleep the MBA it drains the battery, and remains on for over an hour later. Also gets really hot, and no fan kicks on at all.


MacBook Air (13-INCH, MID 2011), OS X Mountain Lion
  • 1. Re: Sleep wake problem
    ScottFreeSBP Level 1 Level 1 (0 points)

    i've got the same problem from boot, except its on a mac pro (the desktop tower) from early 2009

  • 2. Re: Sleep wake problem
    ellisonjay Level 1 Level 1 (0 points)

    I suspect now that some widgets, and apps are setting bad hibernatemodes.

     

    source: https://discussions.apple.com/message/19066192#19066192#19066192

     

    I used pmset -g, and it said I was in hibernatemode 5. I set this (sudo pmset -a hibernatemode 0) closed the lid, and it came back up. I set it to 3, and the same. I moved over to my widget, and set it. Checked my mode, and it was back to 5.

     

    I used `man pmset` it said to only use mode 0, 3, and 25! No others! I again set it (sudo pmset -a hibernatemode 25) this time to 25, and it seems to work fine.

     

    I suspect Apple made changes to their power managment, and disabled older modes. They should have set this correctly in our upgrades, instead of letting us figure it out.

  • 3. Re: Sleep wake problem
    wkoffel Level 1 Level 1 (5 points)

    I can't find hibernatemode = 25 documented anywhere, are you sure that's a real value?  Should be 0,1,3,5, or 7, I believe.  Anyway glad it's working for you.

  • 4. Re: Sleep wake problem
    ellisonjay Level 1 Level 1 (0 points)

    man pmset at the terminal.

     

     

    "We do not recommend modifying hibernation settings. Any changes you make      are not supported. If you choose to do so anyway, we recommend using one      of these three settings. For your sake and mine, please don't use anything      other 0, 3, or 25.

     

    hibernatemode = 0 (binary 0000) by default on supported desktops. The sys-      tem will not back memory up to persistent storage. The system must wake      from the contents of memory; the system will lose context on power loss.      This is, historically, plain old sleep.

     

    hibernatemode = 3 (binary 0011) by default on supported portables. The      system will store a copy of memory to persistent storage (the disk), and      will power memory during sleep. The system will wake from memory, unless a      power loss forces it to restore from disk image.

     

    hibernatemode = 25 (binary 0001 1001) is only settable via pmset. The sys-      tem will store a copy of memory to persistent storage (the disk), and will      remove power to memory. The system will restore from disk image. If you      want "hibernation" - slower sleeps, slower wakes, and better battery life,      you should use this setting."

  • 5. Re: Sleep wake problem
    myazigi Level 1 Level 1 (0 points)

    This help me too. And the following tool works just fine

     

    We just released DeepSleep 2.0 (unrelated to DeepSleep Widget with the same name) and it supports Lion and is ready for Gatekeeper. Check it out athttp://www.axoniclabs.com/DeepSleep/

  • 6. Re: Sleep wake problem
    CedricH Level 1 Level 1 (0 points)

    I have the same problem with my late-2009 iMac. I also tried an SMC and PRAM reset but nothing has worked, even after the update to 10.8.2

  • 7. Re: Sleep wake problem
    Joseph Silva Level 1 Level 1 (0 points)

    Another possibility is flaky harware. Perhaps the non-volatile storage for the power management settings. Assuming that is in the SMC instead of PRAM then perhaps resetting the SMC will help.

     

    http://support.apple.com/kb/HT3964

  • 8. Re: Sleep wake problem
    CedricH Level 1 Level 1 (0 points)

    I have performed an SMC reset but that didn't help sadly. It's still doing this…