Skip navigation

Strange AppStore problem cannot update and download previous...

1384 Views 20 Replies Latest reply: Jun 14, 2013 12:34 AM by Kvargla RSS
1 2 Previous Next
Kvargla Calculating status...
Currently Being Moderated
Dec 2, 2012 5:06 AM



I encountered strange problem with AppStore. There was uptade for one application so I tried to update it. It failed. Recommendation was to use purchases page and update from there. Same problem. I deleted app and try to install it again from "Purachases" it is not posssible anymore for about two weeks. It started to act same on my MacBook and iMac I am getting error "An Error Has Occured" and nothing elese. I was able to download iTunes 11 update without problem but not others anymore. I tried delete plist file, delete cache, sign out and back in and reboot everything and nothing still same behaviour. Any ideas?

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    Multiple computers... Starting to suspect either internet/router issue, or same restriction you're putting on all machines.


    Let's do a test.


    Create a new TEST USER account on one of your machines. Try the MAS from that account. What happens?

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    I'm not so sure this is a problem on Apple's Side.


    Who is your ISP?


    Can you remove your modem from your router, and plug it (modem) directy into one of your Macs? Then I want you to power-cycle the modem, and let's see what happens at that point.

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    Disconnect the Router. Plug your modem directly into your Mac. Make sure internet works (Disable WiFi to make sure), and see if the MAS works better.

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    What a **** puzzling mess.


    Thanks in advance for keeping us posted on this. Maybe someone who's seen this very odd behaviour before can shed some light on it. If going for broke, why not try Google's DNS just so we don't qustion anything.

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    I'm a bit tired so getting confused. To be clear, are you saying that under the Belkin, everything works INCLUDING the MAS/iTunes store?

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.