3 Replies Latest reply: Dec 8, 2012 3:45 PM by a brody
MontFinn Level 1 Level 1 (0 points)

I bought a game called Portal without realising that my Mac 10.4.11 is not compatible. It needs 10.6.6 or higher. I don't know much about these things. How can I make my Mac a 10.6.6? I have 2GB 667 MHz DDR2 SDRAM.

 

Thanks.


iMac, Mac OS X (10.4.11)