Skip navigation

Faderport does not show up in device list

4278 Views 14 Replies Latest reply: Apr 20, 2013 10:13 AM by AndyH7 RSS
psametz Calculating status...
Currently Being Moderated
Mar 21, 2012 11:10 AM

The Presonus FaderPort manual states:

1. Go to Logic Pro | Preferences | Control Surfaces | Setup…

2. In the Setup window, go to New | Install…

Please Note: If the FaderPort is already present in the control surface environment, your FaderPort is ready to use. No setup is required.

3. Select “PreSonus FaderPort” from the list of control surfaces and click “Add”. Close the device list window.

4. In the Setup window, you will now see the FaderPort

In the FaderPort configuration menu to the left, set the Out Port to “FaderPort and the Input to “FaderPort”

Close the Control Surface setup window. Your FaderPort is now ready to use.

--

But FaderPort does not appear in that list. (Note: it does appear in  Audio MDI Setup).

There is a file called Faderport.bundle in the Logic folder of the Faderport folder. Where should it go?

 

Oh here it is in the Faderport under Troubleshooting:

 

Go to MacHD>Applications and CTRL-click on your Logic application. Select “Show Package

PreSonus FaderPort does not show up in the device list in Logic

If you have customized your Applications directory or if you have multiple versions of Logic installed, the

installer may not be able to automatically install the FaderPort.bundle file to the correct path. The bundle file

can be easily installed manually by CTRL-clicking on the FaderPort Installed mpkg. Select “Show Package

contents” from the pop-up menu. Double click Contents>Resources>FaderPort Bundle.zip to unarchive the

bundle folder. Copy FaderPort Bundle>for Logic>FaderPort.bundle.

(This is where I already was).

contents” from the pop-up menu. Go to Contents>MIDI Device Plug-ins and paste the FaderPort.bundle file.

 

Opening Logic, the FaderPort is immediately recognized.

Great! I answered my own question. Hope that helps someone else.

 

Now to figure out "Learn Mode"

AMMO

  • electrik Calculating status...
    Currently Being Moderated
    Mar 21, 2012 2:13 PM (in response to psametz)

    Hey!

     

    I own a Faderport, and there are a TON of documented problems with it, and Presonus is absolutely NO help.

     

    However, there is one thread on the Presonus Forum I found very helpful.

     

    The key is to install the OLDER firmware, with the NEWEST driver.

     

    See the last page of this thread:

     

    http://forums.presonus.com/posts/list/15/10636.page

     

    The older firmware/newest driver combination allows the faderport (motorized fader and all) to work perfectly in 32 bit mode.  However, Presonus has NO support for Logic in 64 bit, so unfortuantley, if you run Logic in 64 bit mode, your faderport will not work.

     

    Hope this helps you!!

  • tankfield Calculating status...
    Currently Being Moderated
    Mar 21, 2012 8:41 PM (in response to electrik)

    I have Faderport working (motor and all) in 64 bit Logic Pro 9.

     

    See my post on the Presonus forum

  • electrik Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 22, 2012 10:19 AM (in response to tankfield)

    Thaaaaank you tank for your post. Just to clarify, when using your faderport successfully in 64 bit do u have both the latest driver and firmware?  Thx again.

  • tankfield Level 1 Level 1 (85 points)
    Currently Being Moderated
    Mar 22, 2012 11:24 AM (in response to electrik)

    electrik wrote:

     

    Thaaaaank you tank for your post. Just to clarify, when using your faderport successfully in 64 bit do u have both the latest driver and firmware?  Thx again.

     

     

    Yes, I used the latest driver and firmware 8 weeks ago. I doubt there's been any updates since.

  • electrik Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 22, 2012 12:44 PM (in response to tankfield)

    Wooot!

     

    tankfield you just woke my Faderport up from a looong hibernation.  Now works in 64 bit.  No longer a paper weight. Many many thanks!

     

    Electrik.

  • electrik Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 22, 2012 7:53 PM (in response to psametz)

    Ya I've got 16gb of ram...

     

    And no, with 4gb of ram there's really no point in 64 bit mode. But there are tons of threads on this forum addressing that issue.

     

    Cheers.

  • Eriksimon Level 6 Level 6 (10,430 points)
    Currently Being Moderated
    Mar 23, 2012 3:12 AM (in response to psametz)

    "with 4gb of ram there's really no point in 64 bit mode" is a myth, I'm afraid. Which I initially also helped spread. Until I actually tested it.

     

    Even with "only" 4 GB of RAM there is a point to 64 bit mode, since Logic in 32 bit mode doesn't actually have a RAM-use-maximum of 4 GB, in reality it is closer to ±2 GB. Around that point Logic starts telling you that you should save, that you're running out of memory (RAM) and if you still add something to the project, it'll crash or "auto-quit". Where your actual RAM could perhaps churn out 1 more GB - that is where 64 bit setting can help, to use "every last drop" of RAM you have. I also strongly advise to use a utility like MenuMeters (free)

    http://www.ragingmenace.com/software/menumeters/

    Install, open System Preferences and open the panel to configure.

    In the Memory tab:

    Enable both the memory meter (free/used) and the "paging"-activity option. When RAM gets really full, this will be evidenced by a lot (the letter "k" indicating 1,000) of "paging" (=RAM-contents being temporarily written to disk or read from disk).

  • Jacob Jackson Calculating status...
    Currently Being Moderated
    Dec 3, 2012 3:31 AM (in response to tankfield)

    Hey Tankfield (or anyone), any chance you can link to that solution again please?


    Cheers

  • tankfield Level 1 Level 1 (85 points)
    Currently Being Moderated
    Dec 3, 2012 4:15 AM (in response to Jacob Jackson)

    Here's how I got my Faderport working with Logic Pro in 64-bit:

     

    1. Download Faderport installer from http://www.presonus.com/support/downloads/FaderPort and install
    2. Download 64-bit Faderport.bundle from http://support.presonus.com/entries/20399677-faderport-logic-64-bit
    3. Open the Applications folder and right-click on the Logic Pro application icon then choose 'Show Package Contents'
    4. Open the Contents folder and then the MIDI Device Plug-ins folder which is inside it
    5. Move the Faderport.bundle that you downloaded into this folder
    6. Start Logic Pro in 32-bit mode (select that mode by choosing Get Info on the Logic Pro icon)
    7. Quit Logic Pro
    8. Start Logic Pro in 64-bit mode (select that mode by choosing Get Info on the Logic Pro icon)

     

    Good Luck Jacob!

  • Martin Gisborne Calculating status...
    Currently Being Moderated
    Dec 5, 2012 2:47 PM (in response to tankfield)

    Hi tankfield,

     

    Thanks for your post, very useful to get the Faderport working. You mentioned that yours was working 'motor and all'. I've just managed to get mine working thanks to your tips but without any motorized fader movement. Any clues on that?

     

    Thanks again.

     

    M

  • tankfield Level 1 Level 1 (85 points)
    Currently Being Moderated
    Dec 7, 2012 1:38 AM (in response to Martin Gisborne)

    Martin

     

    My Faderport motor stops working fairly often - I don't know why. Disconnecting and reconnecting the power and usb cables and re-starting Logic gets it working again.

     

    If you've followed my installation suggestions then I'm afraid I don't have any better ideas, at the moment.

     

    Michael

  • Jacob Jackson Level 1 Level 1 (25 points)
    Currently Being Moderated
    Dec 19, 2012 1:50 AM (in response to tankfield)

    You, Tankfield, Rule.

     

    Thanks very much.

  • AndyH7 Calculating status...
    Currently Being Moderated
    Apr 20, 2013 10:13 AM (in response to electrik)

    Thanks electrik for your tip about using old firmware with latest driver. This has worked for me. I also downloaded the Logic 64 bit bundle (driver) and my fader port works with my logic pro 9 running in 64 bit mode.

     

    I struggled for about 3 days to get my faderport to work and after reading these threads and other forums I got it to work using the combination of old/ original firmware with newest driver. Here is my advice for other people who have had problems getting faderport to work with Logic Pro 9. First of all upgrade your Logic Pro 9 to the latest version using Apple Software Update.

     

    The mistake I was making was that after downloading and running the latest software download for faderport for mac from the Presonus website (Faderport Installer - V135 - Mac. Link below) I updated the FIRMWARE in my faderport as prompted during the upgrade process. The key is to run the faderport installer download which will firstly install the DRIVER into your logic folders. THEN when the faderport firmware updater/ upgrade application starts running (the box pops up on your screen once the logic DRIVER has been installed on your mac) you must quit this as your faderport does this not need this firmware upgrade if you are using logic pro. It actually states on the presonus page for the download:

     

    "Installs native drivers for Cubase SX3+, Digital Performer 4.5+, Logic Express/Pro 7+, Nuendo 2+ and firmware updates for ProTools 6+ and Live.

     

    Therefore I am assuming that the FIRMWARE upgade contained within the installer is for if you are using ProTools 6+ and Live. NOT logic pro. Here's the link to the presonus website for Faderport Installer - V135 - Mac:

     

    http://www.presonus.com/support/downloads/FaderPort

     

     

    If you unwittingly upgrade the firmware in your faderport by mistake simply download the original version of faderport drivers and firmware: Faderport 1.2 Installer:

     

    http://support.presonus.com/entries/21335709-Faderport-1-2-installer

     

    When you run this download it will install the ORIGINAL faderport DRIVER into your logic folders. Then continue with the faderport FIRMWARE upgrade/ update as prompted. Your faderport will now have the original firmware installed.

     

    NOW, you need to go back and and run Faderport Installer - V135 - Mac again and remember to only install the DRIVER and not continue with the faderport firmware update/ upgrade. Your faderport should now work using Logic Pro 9 in 32 bit mode.

     

     

    If you want to run your logic pro 9 in 64 bit mode then you will need to download the 64 bit logic driver from the presonus website. They call it Faderport -   Logic 64 .bundle file. Here is the link:

     

    http:/http://support.presonus.com/entries/20399677-Faderport-Logic-64-bit-

     

    Once you have downloaded the driver you will need to place it manually into the correct folder in your logic application. Go to you applications folder and right-click on Logic Pro app. Go to Show Package Contents. Go into the Contents folder. Drag the 64 bit driver into the folder called MIDI Device Plug-ins. It will overwrite any faderport.bundle file that is in there already. Once you have done this you may find that you need to open up logic pro in 32 bit mode first, then close it down and open it up in 64 bit mode. To change between 64 bit and 32 bit mode close down logic. Right-click on logic pro in your applications folder. Select Get Info and check/ uncheck the 32 bit box as required.

     

    Hope this helps all you faderport sufferers and happy mixing!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.