3 Replies Latest reply: Dec 10, 2012 5:28 AM by RiverdaleMAC
RiverdaleMAC Level 1 Level 1 (0 points)

So, there is a challenging twist associated with this case of missing photos and I hope an expert can provide some advice. Note: This is not related to upgrading from iPhoto '09 to '11 thank goodness!

 

Here is the story in condensed form, with additional details below:

 

MBP stolen but backed up with TM

Used TM on the replacement MBP to browse backup of iPhoto backup of stolen MBP

Restored iPhoto library to new MBP

Open iPhoto on new MBP and browse library

Everything looks OK except *FIVE* Events which show in the Event viewer as blank grey squares. However, the Events have the correct titles and show the correct number of pictures in brackets in the title. In addition, using the trackpad to scroll over the Event there are no thumbnails visible. If I click on the Event all the photos are greyed out but they do have the correct titles and keywords below the grey boxes. If I click on an individual photo I get a black exclamation mark in a grey circle. Interestingly the LAST IMPORT folder in iPhoto DOES show the thumbnails for ALL the missing pictures, all arrange with the correct Event titles. Of course, clicking on any individual picture gives me the same exclamation mark detailed above.

 

 

After reading these support forums I have tried the following:

 

 

1) Viewed package contents ---> the blank Events DO NOT show up as folders in the Finder window

2) Used COMMAND & OPTION to launch iPhoto and checked the following boxes in the REBUILD DIALOG BOX: rebuild small thumbnails/rebuild all of the photos' thumbnails/recover orphaned photos/examine and repair permissions ---> Issue persists

3) Download iPhoto Manager and tried EXTRACTING all the photos from the library --> Photos from missing events still not showing up. Not really surprising given that the VIEW PKG. CONTENTS in #1 above didn't show them either.

4) Used iPhoto Manager to REBUILD LIBRARY --> still doesn't show them

5) Used TM to browse the backup directly --> missing photos have blank placeholders only.

 

 

It appears for what ever reason the photos have been deleted from the backup. I say "deleted", as opposed to "not backup up", because iPhoto has the remnants of the photos (i.e, Events, thumbnails, titles, keyword, etc.). Any suggestions on how to possibly recover these missing pictures. How about the thumbnail versions at least, even in their their low resolution form. Although, I admit I don't know how/where thumbnails are dealt with in iPhoto as they don't seem to show up in the Library package contents.

 

 

Additional info:

 

 

OSX 10.7.5, iPhoto '09 is version 8.1.2, and iPhoto library is 75GB, 139 Events, 28,000 pics

 

 

The day before the MBP was stolen I downloaded a number of photos and did some editing. That night plugged the MBP in and noticed that the Time Machine did a number of backups through the night, although the iPhoto library seems untouched but can't be sure. The following morning, the computer was used for a few hours and thus had plenty of time to complete any backups necessary.

 

 

The *FIVE* Events that are affected seem to be the most recent ones, worked on the night before the MBP was stolen.


Mac OS X (10.7.5)