9 Replies Latest reply: Dec 3, 2012 10:47 AM by mende1
alchemy1215 Level 1 Level 1 (0 points)

So neither the latest Firefox OR the latest Safari works with Leopard.

What are we to do?

 

I am a little peeved and a little panicked at the same time.

 

Is this where I'm being forced to upgrade, ie. I have no choice?

 

Thanks!


PowerMac, Mac OS X (10.5.8), 2.4 GHz Intel Core 2