Skip navigation

On Messages I can't send under my phone number anymore.

354 Views 2 Replies Latest reply: Dec 4, 2012 2:05 PM by Ralph Johns (UK) RSS
KingHyrule64 Calculating status...
Currently Being Moderated
Dec 2, 2012 3:06 PM

So, I've been using Messages for a while now and everything has been working great. I was logged in under my Apple ID and I had the choice to send them under my email or under my phone number.

 

Well, all of a sudden my friend messaged me back asking why I was messaging from my email and not my phone number. I have no idea how to fix this problem.

 

I have logged out and logged back in. I've tried setting things up differently on my phone so that iMessages are only sent from my phone number. I can't think of anything else to do.

 

And I am aware that iChat is not exactly the correct area to post this question, but there was no way for me to post under a 'Messages' area. This was the closest second.

MacBook Pro (13-inch Early 2011), OS X Mountain Lion (10.8.2)
  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)

    Hi

     

    Snow Leopard and the Lion Areas have a category called iChat and iChat Sharing

    (although I tend to only answer here)

     

    Mountain Lion has a Messages Category which I do read and Answer.

     

    If in Messages Menu > Preferences > Accounts > the iMessages account the drop down at the bottom of the right hand side does not list your iPhone Number  and it is also not listed a a Possible nearer the top then remove the Apple ID on the iPhone.

     

    So that is on the iPhone in Settings > Messages > Send and Receive remove the Apple ID

    In Settings > Messages turn Off Messages (Break with the server)

    Wait for  few minutes

    Turn Message Back on.

    After another wait (so the iPhone Number is "registered") then add the Apple ID again.

     

    Now turn Off Messages on the Mac.

    Restart Messages and the app should get an Alert saying the iPhone is using the Apple ID and the iPhone Number  and whether you want to use them in Messages.  (Saying No still lists them but does not make them Active)

     

     

    Sigcopy2.png
    9:53 PM      Monday; December 3, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,815 points)

    thanx.gif  for the Points  icon_correct_big.png

     

     

    Sigcopy2.png
    10:04 PM      Tuesday; December 4, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.